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Introduction 
 
Infothek Database ® is a simple, generic database application with extensive user-
definable indexing and query functions.  The database can be a Microsoft Access 
database or an ODBC database.  The system requires the Microsoft .NET Framework 
2.0 or later. 
 
Make sure that you have the latest version of the program.  The latest version can be 
downloaded from www.informatik.com. 
 
Make sure that you have a good backup of the database files. 
 
 

Requirements 
 
The system requires the Microsoft .NET Framework 2.0.  If you have a fairly recent 
computer model, you probably already have the Framework files.  If not, Framework can 
be freely downloaded from Microsoft (www.microsoft.com).  Please contact support if 
you have any problems finding the Framework. 
 
 

Trial Version 
 
You may use the free trial for thirty (30) days.  After 30 days you must uninstall the trial 
software or purchase a software license.  Please note that once the database reaches 
about 200 records, a nag window is displayed covering a small part of the window.  If 
within the 30 days trial period, you may still work around that nag display.   
 
 

Getting Started 
 
Start up the Infothek Database program.  There are THREE common methods to launch 
the program: 
 

o Click on the Infothek Database icon on the desktop.  
o Or, click on Start button (lower-left corner of window) -> All Programs -> Infothek 

Database. 
o Or, double-click on the Infothek.exe in the Program Files\Informatik Inc\Infothek 

Database folder. 
 
The Archiver program opens in either the ‘Archive’ or ‘Search’ mode.  The program 
opens in the last used mode, or you can specify your preference in Setup (General 
Setup).   Setup can be found in the File menu.  
 
Click on either the ‘Archive’ or the ‘Search’ tab: 
 
‘Archive’ allows you to add and index new records to the Infothek database. 
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‘Search’ allows you to search the database for previously indexed records. 
 
The program opens with the previously accessed database.  The first time that you use 
Infothek, it opens with the Sample database, because you have not yet set up a real 
database.  The Sample database is merely for demonstration; it is over-simplified.  The 
real database that you are about to create can have up to 30 fields and has a large 
number of options, features and functions.    
 
Please read next section about selecting and opening a database. 
 
 
 

Database Selection 
 
The initial version of the Infothek includes a tutorial database that you can use to 
experiment with the software.  The tutorial database is a simple Microsoft Access 
database.  Infothek supports most databases, including ODBC databases. 
 
To select another database, click on the Database menu and choose Select Database.  
Click on the database name that you wish to open and press the ‘Open Database’ 
button.  If the database is not listed in the list box, click on ‘Other’, browse to the folder 
that holds the database file and press the ‘Open’ button.   
 
It is suggested that you give the databases user-friendly, meaningful names.  Once you 
have opened an ‘Other’ database the name of that database will be listed in the 
dropdown list for future selection.  If the database is listed, do not use ‘Other’ again for 
that same database.  
 
The first time you use the database you may be asked to select the table (if more than 
one table exists in the database). 
 
For databases other than Microsoft Access, you should create a UDL file.  The simple 
procedure is explained in a separate section below.  Once the UDL file has been 
created, open it for the first time by clicking on the UDL file; to re-open it again, pick the 
database item from the database list box, as explained above. 
 
Listed database items can be removed from the listing.  In the Database Selection 
window select the item that you wish to remove and click on the ‘Remove’ button.  After 
confirmation, the item will be removed.  Removed items can be re-inserted and the 
database setup specifications reactivated.  In the Windows Explorer, open the DB 
subfolder of the program file (probably C:\Program Files\Informatik Inc\Infothek 
Database\DB\Backup folder).  You will see the ‘removed’ files listed.  To reinstate the 
files, copy them back from the \DB\Backup folder to the  \DB folder.    
 
The next time start the Archive program, the last used database will be pre-selected and 
will open automatically. 
 
When the database opens, the Archive and the Search windows are populated with all 
the fields of the database.  Initially, the fields are listed in the order in which the database 
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was created.  As you will see in Database Setup, the display order of the fields can be 
changed easily.   
 
To change the database again, simply choose Select Database from the Database 
menu. 
 
If the database file is moved or renamed, you will get an error message the first time you 
log on.  Just restart the program, re-select the database and the links will be re-
established.  If the problem persists, review the files in the C:\Program Files\Informatik 
Inc\Infothek Database\DB folder.  Each database must have a .db.xml file and possibly 
one or more .fxml files for setup information.  Do not remove the fxml files. 
 
In special situations where you may need to change the database connection string (for 
example passwords or user names), go to Setup (Database Global) and change the 
connection string.  Caution is advised. 
 
To create a database (Microsoft Access), please read the Create Database section 
below. 
 
 

Archive (Indexing) 
 
Until we build a database, we will use the Sample database.   
 
The Archive option allows you to add and index new documents to the Archive database 
(indexing).   Indexing is straightforward.  There are also many labor-saving functions and 
shortcuts that in some cases can make the indexing virtually automatic.  For these 
options, please see the Database Setup section below. 
 
Forgetting for a moment the extensive shortcuts, the basic method of indexing follows 
these few steps: 
 

• Click on the Archive tag in the main window.  The indexing window opens with all 
database fields listed.  If the primary key field is an auto-incrementing value, the 
field will be disabled since you never need to make or change the entry.  The 
auto-incrementing value will be assigned by the system when you save the 
record.   

 
The fields are listed in the order set in the database.  You can change the display 
order in Setup (Database Global). 

 

• Enter the index data into each field and press the Tab key to move to the next 
field.   

 

• Press Function Key 3 to copy the data from the same field in the previously 
saved record.  The system immediately validates the entry and tells you if there 
is an error.  Make sure that numeric fields have a valid number, and that date 
fields have a valid date entry.   
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• To enter a date, you can use the calendar icon, or use the Calendar option from 
the File menu.  Click on the date, and the system will insert the selected date in 
the field that has the focus.  To select the today’s date, or the date of the current 
document, right-click on the calendar and select the option.  To cancel the 
calendar without making an entry, click on the calendar button again, or click 
anywhere on the window background.  

 

• For copy/paste Windows Clipboard functions use the standard Windows 
shortcuts:  Ctrl+C for copying and Ctrl+V for pasting. 

 

• You can clear all entries with the Clear icon in the toolbar, or the clear function in 
the File menu, or Function Key 7.  All fields are cleared.  But you probably want 
to confirm the entry.  To confirm, click on the Confirm icon (check mark), or 
choose the option from the File menu or the corresponding Function Key 
shortcuts Ctrl+U.  Hint!  When indexing the next document, don’t forget to use the 
Function Key 3 to repeat entries from the previous record. 

 
 

Search (Query) 
 
The Archiver has powerful, yet easy-to-use query functions. 
 
Press the Search tab in the main window.  The Search window opens. 
 
Most query criteria and specifications can be saved so that they become the default for 
the next query.  To save the criteria and specifications, choose ‘SaveSettings’ from the 
File menu.  
 
Up to four search criteria can be specified for each query.  Select the search field and 
the Search Operator from the pull-down lists and type in the Search Criteria.  If your 
search covers more than one field, by default the query command assigns the AND 
operator.  If necessary, change the operator to OR.  If your search extends to three of 
four search fields, and the query has at least one each of an AND operator and an OR 
operator, the AND operators are executed first, as per the following schema: 
 

(aaa AND bbb) OR  (ccc AND ddd) 

(aaa AND bbb and ccc) OR ddd 

Aaa OR (bbb and ccc and ddd) 

 
The following search operators are available and should cover all your needs. 
 
STARTS WITH for strings, numbers, dates 
STARTS NOT WITH for strings, numbers, dates 
IS EXACTLY for strings, numbers, dates, Boolean 
IS NOT for strings, numbers, dates, Boolean 
INCLUDES for strings, numbers, dates 
MORE OR EQUAL THAN for numbers and dates 
LESS OR EQUAL THAN for numbers and dates 
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Hint! The STARTS WITH can be used in virtually all cases.  If in doubt, use the STARTS 
WITH operator. 
 
When the search criteria are entered, click on the Search button, or select Run Search 
from the File menu, or press Function key 8.  The matched items are listed in the query 
results table. 
 
Note that the fields in the result table are listed in the original database field order.  The 
field order can be changed in Setup (Database Setup).  It is suggested that for practical 
reasons the FilePath and the ID fields are placed last.  The initial sort of the displayed 
records is also according to the field order set in Setup / Global Database (Query 
Results). 
 
With some experience and practice, you will quickly master virtually any query type. 
 
The search specifications can be saved as a default.  To save the specifications, choose 
the Save Settings option in the File menu.  
 
To sort the result table, simply click on any of the field headers.  The initial sort of the 
displayed records is also according to the field order set in Setup / Global Database 
(Query Results).  To move the columns, drag the column header to the desired 
location. 
 
If the data is truncated and you need to see the full details, click on the Details button.  
To resize (widen) the column width in the table, drag the right border of the field 
header.  To save valuable screen space, the window is kept small; some database fields 
may not be shown.  As explained above, the field display order for either the indexing or 
search (or both) can be changed in the Setup (Database Global).  You may want to 
consider moving the important fields to the front.   
 
Due to the limited display area, some of the columns may be hidden.  Use the horizontal 
scroll bar to view the hidden columns.  You can also re-arrange the columns, i.e. move 
the most important column to the front by simply dragging the column headers to the 
desired position.  To quickly see the data of all columns, right-click on the record row; 
the data is then displayed as long as you hold down the mouse button. 
 
To view the detail of all data fields, click on the Detail button.  The Detail window stays 
open until you close it.  The data is refreshed each time you click on a record.  This 
option allows you to copy the data into the Clipboard. 
 
To edit listed records, first select the records.  Several records can be selected.  To 
select a contiguous range of records, click on the first record in the left header cell 
(empty gray cell), and while holding down the Shift key, click on the left header cell of the 
last record in the range.  To select non-contiguous records, click on the records in the 
left header cell while holding down the Ctrl key.  To select multiple records you can also 
select them simply by right-clicking on a data cell.  After the records have been selected, 
click on the ‘Edit Records’ button, or choose the option from the File menu.  The 
Indexing window now opens.  Click on the arrow button next to the Selected Records’ 
pull-down list to move to the next record, or select the record from the pull-down list.  
Make the necessary corrections to the record and confirm the entry by clicking on the 
Confirm icon (check-mark) or choosing the Confirm option in the File menu.  Always 
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confirm the change before you move to the next record.  For batch updating, see the 
Batch Updating section in this manual.  
 
To delete listed records, first select the records.  Several records can be selected.  To 
select a contiguous range of records, click on the first record in the left header cell 
(empty gray cell), and while holding down the Shift key, click on the left header cell of the 
last record in the range.  To select non-contiguous records, click on the records in the 
left header cell while holding down the Ctrl key.  Or, you can select single or multiple 
files by simply right-clicking on the data cell.  From the File menu, choose ‘Edit/Delete 
Selected Records -> Delete Selected Records (or Delete Selected Records and Indexed 
Image Files).    
 
The Save Selected Record Data as Text File option creates a readable text file with 
the data of the selected records.  The file includes both the field labels and the data, 
arranged in a vertical layout. 
 
The Print Selected Record Data option creates a temporary text file with the data of the 
selected records and displays the file in Notepad or in the program that is associated (in 
Windows setup) with the .txt extension name.  The file includes both the field labels and 
the data, arranged in a vertical layout.  The file can then be printed with Notepad’s 
printing functions. 
 
For diagnostic purposes, the SQL query string can be viewed by choosing the View SQL 
String in the File menu. 
 
The Search window can be cleared with the Clear Screen function in the toolbar (‘cross-
out’ icon) or File menu, Function Key 7. 
 
Need to know the Size of the Database?  Choose Get Database Size in the file menu. 
 
For Global Editing, see separate section below. 
 
For Exporting, see separate section below. 
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Launch Linked Applications 
 
The program allows you to open other applications with the current data (last clicked 
cell) being passed to the launched application as an argument (parameter). 
 
Applications can be launched from the embedded Image Viewer and the Search 
window. 
 
Select up to three (3) applications from Setup (General Setup).  When you restart the 
program, the applications will be listed in the embedded viewers’ File menu, and icons of 
the applications will be shown in the Search window’s tool bar.  The icons of the 
applications will bear the first letter of the application.  Simply click on the icon and the 
application will be launched with the current file name passed as an argument.   
 
You can create your own icons.  Simply place your icons in the program folder (same 

folder as the Archiver program’s executable file).  The icons MUST be named AppA.ico 

and/or AppB.ico and/or AppC.ico.  The graphics format of the icon image need not 

be an icon; it can be a BMP, PNG, etc., but the extension must be .ico. 

 
Alternatively, you can copy the file name of the currently open image file to the Windows 
Clipboard, then start an external application and paste the file name in that application.  
The Copy File Name to Clipboard function can be found in the Edit menu of both the 
embedded Image Viewer and the PDF Viewer. 
 
Custom Arguments.  By default, the file name is passed to the Application. Additional 
argument elements can be passed with the Custom Arguments options.  Use [f] as the 
placeholder for the filename and [d] as the placeholder for the filename’s directory.  For 
example, to open a folder that contains the current file, select the 

c:\windows\explorer.exe as the application and set the Custom Argument to [d].  

To merely select the folder (without opening it), set the Custom Argument to 

/select,[d].  To force the filenames to be encapsulated in single quotes, for 

example, use the string  “[f]” (including the quotes).  To add a switch, for example, 

the string would be /a “[f]” 

 
 
 
 

Create a Database 
 
You will need to create a database that is specific to your indexing needs.  Archiver 
supports databases up to 30 fields.  One of the fields must be a primary key with a 
unique value. 
 
The database can be a Microsoft Access database or almost any ODBC database.  You 
can create the database with your database software, or you can use the simple 
database creation tool supplied with Archiver (Microsoft Access database).  If you create 
a database with your database software, keep the following in mind: 
 

o The number of fields must not exceed 30.  
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o One field must be a primary key field.  It is suggested that you make primary key 
field an auto-incrementing field (select Auto-incrementing from the pull-down list). 

o Ensure that the field names are compatible (no reserved words, no spaces, no 
special characters, no leading numbers).  

o If possible, the database should have a single table. 
 
To create the database with the Archiver Database Builder tool, follow these steps: 
 
From the Database menu, choose Create New Database.  The Database Builder 
window is displayed.  
 
Type the field name in the text boxes in the first column.  Do not use reserved words, 
such as Date, Name, Text, Where, Level.  The file name must not start with a number, 
for example 2006Docs.  The file name must not have spaces or include special 
characters. 
 
Specify the data type from the pull-down list.  For Text fields, enter the maximum 
number of characters.  Generally, for all fields, you should check the 'Indexed' checkbox.  
If the database should allow a blank entry, then un-check the 'Allow Null' box. 
         
One field must be designated as the 'Primary Key Field'.  It is recommended that you 
create an auto-incrementing primary key field; select ‘Auto-increment Primary Key’ from 
the Data-Type pull-down list.  Alternatively, specify the primary key field in the right-side 
column. 
 
There is a maximum of 30 fields; one table per database.  The table name is 
automatically assigned to be 'Archive'. 
 
Click on the OK button to build the database.  On the prompt, enter a new database 
name.  Make the database a short but meaningful name, no spaces in the name.  The 
database name must have an .mdb extension name. 
 
Databases with password protection must be created with database software, for 
example Microsoft Access, and the database must be opened via a UDL file.  For a 
discussion on UDL, see separate section in this manual.  If you do not use a UDL, the 
connection string must include a reference to the password and user ID, for example: 
Provider=Microsoft.Jet.OLEDB.4.0;Password=[Password];User 

ID=[Id];Data Source=C:\SomeDir\documents.mdb;Persist 

Security Info=True 

 
 
 

Update and Delete Records 
 
Deleting or updating existing records are done via the Search option.  Run a search that 
will identify the record(s) that you wish to update or delete.   
 
To edit listed records, first select the records.  Several records can be selected.  To 
select a contiguous range of records, click on the first record in the left header cell 
(empty gray cell), and while holding down the Shift key, click on the left header cell of the 
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last record in the range.  To select non-contiguous records, click on the records in the 
left header cell while holding down the Ctrl key, or simply right-click on a cell of the 
records that you wish to select.   Click on the ‘Edit Records’ button, or choose the option 
from the File menu.  The first of the record is then displayed in the Indexing window.  
Click on the arrow button next to the Records pull-down list to move to the next record, 
or select the record from the pull-down list.  Make the necessary corrections to the 
record and confirm the entry by clicking on the Confirm icon (check-mark) or choosing 
the Confirm option in the File menu.  Always confirm the change before you move to the 
next record.   
 
For batch updating, see the Batch Updating section in this manual.  
 
To delete listed records, first select the records.  Several records can be selected.  To 
select a contiguous range of records, click on the first record in the left header cell 
(empty gray cell), and while holding down the Shift key, click on the left header cell of the 
last record in the range.  To select non-contiguous records, click on the records in the 
left header cell while holding down the Ctrl key, or simply right-click on a cell of the 
records that you wish to select.  From the File menu, choose ‘Edit/Delete Selected 
Records -> Delete Selected Records.    
 
For Global Update and Delete options, see the Global Updating and Deleting section in 
this manual.  
 
 
 

Global Updating and Deleting of Records  
(Advanced Use) 
 
The recommended approach to updating and deleting records is via the Indexing 
window, as explained in the Update and Delete Records section in this manual.  
However, there is also a global method.  If you use the global method, it is essential that 
you make a good backup of the database before you proceed.  It is strongly 
recommended that you first practice with a dummy database. 
 
Run a search that will identify the record(s) that you wish to update or delete.   
 
Select the records that you wish to update.  To select a contiguous range, click on the 
left row label (left header cell) of the first record in the range, and while holding down the 
SHIFT key, do the same for the last record in the range.  To select non contiguous 
records, select the records by clicking on the left row label while holding down the CTRL 
key, or simply right-click on a cell of the records that you wish to select.   
 
 
The option allows you to update the selected records of one specified field.  The 
replacement value can be a fixed text, and you can include placeholders.  Placeholders 
represent all or part of the value of the original record data.  The following placeholders 
are supported: 
 
[*] represents the entire original data 
[5] represents the first 5 characters of the original data.  You can use any number. 
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[-5] represents the last 5 characters of the original data.  You can use any number.  
[2:3] captures 3 characters starting from the second character to the left 
[-5:3] captures 3 characters starting 5 characters from the end. 
 
The specification can be a mix of fixed text and one or more placeholders. The numbers 
in the samples above are just for illustration; you can use any numbers that are valid 
within the context of the data string. 
 
Examples global update specifications: 
 
DEC[*] 
[*]ABC 
ABC[2]XX[[-1] 
ABC[2:2] 
 
 

Setup 
 
The Setup is accessible from the File menu of the main window.  If you don’t see the 
menu item, click on the Search or Archive window and try the menu again.  Setup has 
four distinct sections, each accessible by clicking on the corresponding tab: 
 
a) Global Database  
b) Database Fields  
c) General Setup   
 
(The setup data is stored in .fxml files in the C:\Program files\Informatik Inc\Informatik 
Archiver\DB folder.  If a database is deleted and no longer used; the corresponding .fxml 
file should be deleted.) 
 

Global Database 

 
The Database Setup allows you to specify default settings for the currently open 
database. 
 
Setup has three options: 
 

o Re-order the sequence of the fields for indexing 
o Re-order the field sequence for searching.  Simply move the fields with the 

arrows.   When done, click on the Save button and close the window.   
 
The Advanced section shows various settings for information only, although the 
connection string can be changed; use caution. 
 
 Click on Save button to save the changes. 
The program needs to be re-started before the new settings take effect. 
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Database Fields 

 
The Setup (Database Fields) allows you to specify a host of default options for posting 
records (indexing of documents).  The list of default options is so extensive that in some 
cases the entire indexing can be automated. 
 
From the Database menu, choose Database Setup.  The Database Setup window 
opens.  Click on the Database Fields tab. In the upper left section of the window, choose 
the field for which you want to create default entries.  The default options are as listed 
below.  After you have made the entries, click on the Save button, then choose the next 
field.  When done, close the Database window.  The program needs to be restarted 
before the new settings become effective.   
 
Defaults 
 

[DATE] 
Inserts the current system date in the short format specified in Windows setup, 
for example 01/01/06. 
 
[USER] 
Inserts the current user name. 
 
[COPY] 
Copies the field entry of the preceded indexed record. This option is effective 
only for online indexing; it cannot be used for batch processing.  
 
[TICKS] 
Inserts the system tick (date and time in one-quarter-millionth of a second).  This 
option can be used to create a virtual-unique value.  The field must be of  LONG 
data type, or else must accommodate 18 characters. 
 
[XML] xxxxx 
Reads an XML file whose file name is identical to the image file name (same 
folder), except for the .xml extension name.  The xxx string represents the data 
element of the XML table, for example Customer in the sample below. 
 
Example: 
 
<Record>   
    <Customer>John Smith>  
    <Account>1234567>  
 </Record> 
 
 
[BATCH_CONSTANT1], [BATCH_CONSTANT1] 
 
These options are used for batch processing only.  See section on Batch 
Processing. 
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DATABASE LOOKUP 
See Database Look-up below 
 

 
Mask 
 

The Mask option changes the entry to a fixed format.  In the specification, each 
variable letter or number is represented by a single question mark.  For example, 
to format a text to a phone-number format, for example, specify (???) ???-????.  
An entered string of 8001234567 will convert to (800) 123-4567 when you leave 
the indexing field.  The only wildcard character allowed is the question mark.  
 

 
Dropdown List 
 

The pull-down list can be specified in two ways: 
 
a) for short lists, simply type in the items, separated by a pipe character, for 
example: 
 
Washington | Baltimore | New York | Boston 
 
For a long list, create a text file, one line per item, and in the Database Setup 
refer to the text file, for example 
 
C:\somedir\dropdownlist.txt 
 
The drop-down list can be overwritable, where the user can type it other text, or 
non-overwritable, where only items from the pull-down list can be selected. 
 
The drop-down list can be either sorted alphabetically, or left in the unsorted 
state (in the order the items have been entered).   
 

 
Match 
 

The Match option verifies that the entry matches one of the specified formats. The 
Match option uses the LIKE operator and thus supports various wildcard characters, 
such as 
 

• * for one, none or several characters of numbers 

• ? for a single character or number 

• # for a single number 
 
Database Lookup 
 

If Database Lookup is specified for a field, a button in the indexing window is 
displayed next to the field.  Which pressed, an SQL query is executed and the 
look-up database opens with the results displayed in a data grid.  The user can 
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select the entry from the displayed database grid.  The Database Lookup 
requires two specifications:  a) the connection string and b) the SQL query string.   
 
The syntax of the connection string depends on the type of database you use for 
the lookup.  The connection string for a MS Access database typically would be 
(example): 
 
Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\xyz\xyz.mdb 
 
The syntax for the SQL query is a bit more complex, but simple if you have some 
familiarity with SQL language.  A sample of an SQL query string would be: 
 
SELECT aaa, bbb, ccc FROM ttt WHERE ddd LIKE ‘<n>’ 
 
Where aaa, bbb ccc are the fields of the lookup database that you want to list.  
To list all fields, use the ‘*’ wildcard character.  If the field names have spaces or 
are reserved words, encapsulate them in square brackets.  To be safe, always 
use square brackets. 
ttt is the name of the table of the lookup database. 
ddd is the field in the lookup database that you wish to query. 
n is the field number of the index database (not the lookup database) that holds 
the value that is used in the query.  Use the field numbers that are shown in the 
Database Setup (not necessarily the field order).  If you enter a ‘<?>’, the system 
will prompt you for an entry.  You can also enter a static text.  Don’t forget the 
encapsulating quotes. 
 
Examples of the SQL query string: 
SELECT [Account], [Customer] FROM [MyTable] WHERE [Account] LIKE ‘<3>’ 
SELECT * FROM [MyTable] WHERE [City] LIKE ‘Boston’ 
SELECT* FROM [MyTable] WHERE [City] LIKE ‘<?>’ 

 
 
Read from XML File 
 
 See Defaults above 
 

General Setup 

 
The Setup (General Setup) allows you to specify settings that have global reach.  
 

o Applications to be Launched.  See Launch Linked Applications section in this 
manual. 

 
o Custom Arguments.  By default, the file name is passed to the Application.  

Additional argument elements can be passed with the Custom Arguments 
options.  Use [f] as the placeholder for the filename and [d] as the placeholder for 

the filename’s directory.  For example the custom argument  /select, [d] 

would pass a string like ‘/select, c:\somedir’ to the application.  If the filename 



 16 

must be encapsulated in quotes, make sure that you add the quotes, for example 
/a “[f]” 

 
                     
 

Import Database 
 
Tab-delimited text files can be imported to the database.  The import function allows you 
to re-order or omit fields in the tab-delimited file.  Make sure that all fields have a 
correctly formatted value.  If the receiving database has an auto-incrementing field, any 
values in the tab-delimited file relating to that field will be ignored and the system will 
assign auto-incrementing numbers. 
 
The import function can also be used to re-build a database.  Simply export the old 
database to a tab-delimited file, then import the file to the new database. 
 
Before you import a file to an existing database, make sure that you have a good backup 
file of the database. 
 
The import function can be found in the Files menu of the ‘Archive It’ window. 
 
Before you open the Import function, select the database to which you are importing 
data.  Choose the Import function from the File menu in the Archive It window. The 
system first prompts you for the tab-delimited text file.  Select the tab-delimited text file.  
The Database Import window opens, listing in the left column all the fields of the 
receiving database.  Next to each field you will see a pull-down list with the values of the 
first record in the tab-delimited file.  From the listed values you should identify the fields 
of the tab-delimited file.  Match each field of the receiving database with the 
corresponding field from the pull-down list.  If you do not associate a field, the field will 
be left blank. For auto-incrementing fields, you can leave the field un-associated. 
 
Please pay particular attention to the following: 
 
a) make sure that the data type are compatible. 
b) ensure that there is no conflict with primary key fields. 
c) if you import to an existing database, make a full backup before you run the import 
function. 
 
Errors are posted to the error log (C:\Document and Settings\[USER]\Application 
Data\Archiver\error_log.txt) 
 
   
 

Export Database 
 
Selected records or the entire database can be exported as a tab-delimited or as an 
XML file. 
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The export option can be found in the File menu of the Query window.  Run a query to 
enable the menu items. 
 
To export the entire database, click on the File menu and choose Export Database -> 
Export Complete Database.  In the ‘Save’ Dialog, enter the output file name either with a 
.txt or .xml extension. 
 
To export the records listed in the query results table, run a query to locate the records.   
Click on the File menu and choose Export Database -> Export Listed Records.  In the 
‘Save’ Dialog, enter the output file name either with a .txt or .xml extension. 
 
 
 

Log Files 
 
The program can maintain two logs: 
 
File Access Log: 
  
This option is operational only in the licensed version and must be activated by the 
System Administrator with the EnableUserAccess utility.  The EnableUserAccess utility 
is available from Technical support (the license registration code is required). 
 
Each time a document is opened, the user name and date/time is logged.  The name 
and location of the log file is specified with the  EnableUserAccess utility 
 
 
Error Log: 
 
Batch processing errors are logged for later review and corrections. 
The log file is in the C:\Documents and Settings\[USER]\Application Data\Archiver 
 
Both log files should be cleared from time to time.  It is up to the system administrator to 
ensure that the access log file is not tempered with.  For special software compiles that 
use secure log files, please contact the software developer.  
 
 

Passwords - Access Permission 
 
A simple access security (basic) is available.  The method allows only authorized users 
to enter the program.  The security is not temper-proof but allows for some level of 
security.   
 
This option is operational only in the licensed version and must be activated by the 
System Administrator with the EnableUserAccess utility.  The EnableUserAccess utility 
is available from Technical support (the license registration code is required). 
 
You may also want to use separate password protection for database access. 
 



 18 

 
 

UDL - Universal Data Link File (.udl) 
 

The UDL file is a Microsoft concept that simplifies the database connections.  
You can use UDL’s with all databases, but it s highly recommended for all 
databases other than Microsoft Access.   
 
The Data Link File (Universal Data Link – UDL) provides a simple method for 
specifying database connection strings.  The database connection command 
simply points to the UDL file which contains all information needed to open the 
database. 
 
Data Link Files are created as follows (see also Windows reference manuals): 
 

1. In Windows Explorer select the folder where you want to create the UDL 
file. 

2. From File menu in the Windows Explorer, select New, then select Text 
Document. 

3. Assign the new file a file name of your choice; it must have a .udl 
extension name.  It is suggested that you save all the UDL files together in 
one folder, ideally in the same folder as the Docudex program files. 

4. Right-click on the newly created and renamed file, and select Properties 
from the pull-down list. 

5. Click on the Provider tab and select the appropriate provider (for example, 
for MS Access you would normally choose the Microsoft Jet 4.0 OLE DB 
Provider).  Review your database reference manual for further 
instructions. 

6. Click on Next button, or choose the Connection tab. 
7. Select the database file (use the Browse button to find the database file) 
8. Click on OK to confirm. 

 
If you are creating a UDL file for an ODBC database, or for advanced MS Access 
use, you may also need to make certain entries in Database Setup (see 
Database Setup section). 
 
 

Trouble Shooting 
 
(If you get an error message ‘Syntax error in INSERT INTO Statement’ then most 
likely the database has incompatible field names. Check the field names for reserved 
words, incompatible special characters, spaces in the name, field names starting with a 
number.  Please see the rest of this section for more information.)   
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Copyright and Trademarks 
 
Copyright 2006-2009 Informatik Inc and J Buchmann.  All Rights Reserved. 
‘Informatik Archiver’ is a trademark of Informatik Inc. 
 
Infothek ® is a Registered Trademark of Informatik Inc.  NET Framework and Microsoft 
Access are trademarks of Microsoft Corporation.  Other product names and expressions 
may be trademarks of the respective owners. 
 
 

Technical Support 
 
For contact information, please visit www.informatik.com/company.html 
 
 

Licensing 
 
For Licensing and ordering information, please visit www.informatik.com. 
 
 

Related Software 
 
Informatik Inc offers a host of other software products, including: 
 
Scanning software:  Infothek Scan 
Manipulation of TIFF Pages:  AppendTIFF 
Markup of TIFF Files: Imagistik Markup) 
PDF utilities: TIFF-to-PDF, PDF-to-TIFF 
TIFF and PDF drivers 
And more 
 
Please visit www.informatik.com 
 
 
 
 

License, Warranty, Disclaimer  
 
Please read the terms carefully before installing and using the software, as such conduct 
will indicate your acceptance of all of the terms of this license agreement.  If you do not 
agree with the terms, the software cannot be licensed to you and you must un-install and 
return the software to Informatik Inc, or its supplier or distributor. 
 
This License Agreement is a legal agreement between Informatik Inc. ("Licensor"), a 
Delaware Corporation, and you, the user ("Licensee"), and is effective the date Licensee 
installs the software. 
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This Agreement covers all materials associated with the Infothek Database software, 
including, without limitation, the downloadable software product, online documentation, 
and any additional supporting electronic files (herein, the "Software"). 
 
The evaluation version may be used for 30 days after installation.  It is unlawful to use 
the software after the 30 day evaluation period without licensing the software and paying 
the license fees.  If a license is not obtained before the expiration of the 30 day 
evaluation period, the Software must be un-installed and destroyed. 
 
1. GRANT OF LICENSE 
Licensor hereby grants to you, and you accept, a nonexclusive license to use the 
Software according to the following condition: 
 
You may use the Software on one (1) computer (PC or workstation) owned, leased, or 
otherwise controlled by you for personal or business purposes, and only as authorized in 
this License Agreement.  The Software may not be used on other computers, nor may it 
be used by, or transferred to, other computers over a network. 
 
2. LICENSOR'S RIGHTS 
Licensee acknowledges and agrees that the Software is proprietary to Licensor and 
protected under international copyright law. Licensee further acknowledges and agrees 
that all right, title, and interests in and to the Software, including associated intellectual 
property rights, are and shall remain with Licensor. The License Agreement does not 
convey to Licensee an interest in or to the Software, but only a limited right of use that 
may be revoked in accordance with the terms of this License Agreement. 
 
3. OTHER RESTRICTIONS 
This License Agreement strictly forbids distribution of the Software with Licensee's 
application. Distribution of the Software with Licensee's application requires separate 
authorization and the payment of license fees. 
  
Licensee agrees to make no more than one (1) back-up copy of the Software. Licensee 
agrees not to assign, sublicense, transfer, pledge, lease, rent, or share the rights 
assigned under this License Agreement. Licensee agrees not to reverse assemble, 
reverse compile, or otherwise translate the Software. 
 
4. TERM 
This License Agreement is effective when Licensee installs the Software and shall 
terminate only if the terms of this License Agreement are broken. Licensee agrees to 
destroy the Software upon termination of this License Agreement. 
 
5. NO WARRANTY; LIMITATION OF LIABILITY 
LICENSEE ACKNOWLEDGES THAT THE PROGRAM IS PROVIDED ON AN "AS IS" 
BASIS WITHOUT WARRANTY OF ANY KIND. LICENSOR MAKES NO 
REPRESENTATIONS OR WARRANTIES REGARDING THE USE OR 
PERFORMANCE OF THE SOFTWARE. LICENSOR incl. DEVELOPER, 
COPYRIGHTHOLDER, DISTRIBUTOR) EXPRESSLY DISCLAIMS THE WARRANTIES 
OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. LICENSOR 
SHALL HAVE NO LIABILITY TO LICENSEE OR ANY THIRD PARTY FOR ANY LOSS 
OR DAMAGE CAUSED, DIRECTLY  



 21 

OR INDIRECTLY, BY THE SOFTWARE, INCLUDING, BUT NOT LIMITED TO, ANY 
INTERRUPTION OF SERVICES, LOSS OF BUSINESS, LOSS OF DATA OR SPECIAL, 
CONSEQUENTIAL OR INCIDENTAL DAMAGES. 
 
6. GOVERNING LAW 
This License Agreement shall be construed and governed in accordance with the laws of 
Pennsylvania.  
 
7. SEVERABILITY 
Should any court of competent jurisdiction declare any term of this License Agreement 
void or unenforceable, such declaration will have no effect on the remaining terms 
hereof. 
 
8. NO WAIVER 
The failure of either party to enforce any rights granted hereunder or to take action 
against the other party in the event of any breach hereunder shall not be deemed a 
waiver by that party as to subsequent enforcement of rights or subsequent actions in the 
event of future breaches. 
 
 
 
 
 
 


