Login


Register | Recover Password

Search Results Problems

Home Forums OpenDoor Support Search Results Problems

This topic contains 7 replies, has 3 voices, and was last updated by  admin 7 months, 2 weeks ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1695

    admin
    Key Master

    If you do a search, and you get a message like “There are no results.” (or similar) OR you are not getting the correct results:

    You have probably set up the search results page correctly, but the theme isn’t finding any listings. Make sure you have entered all the “required” information for each listing. What is required? Anything that is searchable is required. So look at your search form and note what it is searching for, and then make sure those fields are filled out for every  listing.

    If you do a search, and you get a “Page Not Found” page:

    Go to Settings -> Permalinks, and make sure the first choice is NOT chosen. Even if it is not chosen, click on the update button anyway to refresh the page

    Also, look at the URL in the address bar after doing a search. If you see “/index.php/” in the URL, then you must go to Theme Options -> Miscellaneous -> Search Results Page Fix. Choose “yes” from the dropdown.

    If still after all this you get “Page Not Found”, it is possible that the theme is not finding the Page ID for the search results page. In this case you must find this ID number, and manually enter it in Theme Options: To find the Page ID number for the Search Results page, go to the Pages tab, and find the Search Results page. Mouse over the “edit” link, and look down in the status bar at the bottom of your web browser. You will see a URL, which contains a number in there somewhere. That is the Page ID number. Remember that number, and now go to Theme Options -> Miscellaneous -> Search Results Page ID. Enter the number in there, and save the page.

    You may have a Search “Cookie” problem

    The search relies on browser cookies to function correctly, and if you have bad cookies, you can sometimes get no results or incorrect results.

    This can happen during “development” of your site, and visitors will never have this problem.

    Do this to clear your search cookies so “you” can see search results like everyone else: In each search dropdown, choose item #2 or higher. Then right after, choose the first item. Doing that will clear the cookie for that search parameter. Do the same for all your search dropdowns. Now try doing a search.

    If after all this you still can’t search

    Email me your WP login, along with an explanation of the problem, and I’ll help you out. Send your email from my profile page so I can verify your purchase: http://themeforest.net/user/buchmanndesign

    • This topic was modified 1 year, 5 months ago by  admin.
    • This topic was modified 1 year, 5 months ago by  admin.
    • This topic was modified 1 year, 5 months ago by  admin.
    • This topic was modified 1 year, 5 months ago by  admin.
    • This topic was modified 1 year, 5 months ago by  admin.
    • This topic was modified 1 year, 5 months ago by  admin.
    • This topic was modified 1 year, 5 months ago by  admin.
    • This topic was modified 1 year, 4 months ago by  admin.
    #3390

    susanbry
    Participant

    Hi,

     

    The problem I have is that I want to translate the search form fields like “location”, “bedrooms”, etc.

    On the themes options I have put one line per language (I want English, Spanish and German) but I see all the three languages on the options dropbox of the search form.

     

    Shall I do it through .mo and .po files?

    See it on

    http://www.bryproperties.com

     

    Thank you

    #3399

    admin
    Key Master

    The theme does not use .mo and .po files. But there is a qTranslate plugin requirement. Have you installed and activated that plugin?

    #3400

    susanbry
    Participant

    I am reading the docu and I now understand how the translations work.

     

    Question: Do the qTranslate shortcodes work here. I mean putting [:en] instead of the brackets form <!–:en–> ?

     

    Thank you

    #3401

    susanbry
    Participant

    Yes, shortcode works. My mistake was I did not put each one in a different line. Now I got it right.

     

    Thanks a million for your fast response and the fantastic design!

    #3405

    admin
    Key Master

    I didn’t know you could use the shortcodes there. So you say you have to put each shortcode on a separate line? If so, this seems like a much easier way to translate than what I’m doing now.

    #3989

    rossymoreno
    Participant

    Hello, I have problems search results, all properties are not related and appear 1 or sometimes no. In addition, some properties do not have location in Google Maps and do not know how correct that the correct location of Google Maps does not leave. Thank you, This is te site an fail

    http://espacioshabitat.com/resultados-de-busqueda/

     

    #3996

    admin
    Key Master

    What do you mean “all properites are not related”? Are you saying the results are not exactly what you search for? The search seems correct to me. Can you explain an exact search that you do that doesn’t give proper results? For Google Maps, make sure the property has a valid address set, otherwise Google will not be able to find it.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.