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Important:  Make sure that you backup the database and image files regularly 
and that you keep the backup files in a different and safe location.   
 
Getting Started  
 
Installation 
 
If you downloaded the software from the Internet, locate and run the self-extracting 
docu100s.exe file. 
    
If you are installing from a CD, insert the CD, open the Infothek Docudex folder and run 
the setupexe.exe or setup.exe file.  Follow the prompts.   
 
If you are installing the program on Windows 95/98/Me, please read section on MDAC 
below. 
 
After the installation, restart Windows. 
 
It is imperative that you spend a few moments going over the Tutorial included in this 
document. 
 
 
 
MDAC (Microsoft Database Access Connectivity) and JET Engine 4.0 
 
Infothek Docudex requires the MDAC and JET Engine 4.0 files.  If you get an error 
message when opening a database, you may be missing the MDAC and/or JET Engine 
4.0 files. Both are free downloads from the Microsoft web site. 
 
If your computer runs Windows XP or if you have Microsoft Access installed, then you 
already have the MDAC and JET Engine files.  If your computer runs on the Windows 
95, 98 or ME platform, you may not have these files. To download go to 
http://msdn.microsoft.com/data/downloads/default.aspx and download the lowest 
available version of MDAC.  If you download MDAC 2.8 then you must also download 
the JET Engine 4.0 (since MDAC 2.8 no longer includes the JET engine 4.0).  
 
 
Tutorial 
 
It is imperative that you spend a few moments going over the Tutorial included in this 
document. 
 
 
Graphics Formats 
 
The basic version of the program includes the filter files for TIFF, BMP and JPEG 
formats only. 
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The following additional file formats are supported if you download the appropriate 
graphics filters from www.informatik.com/infothek.html: 
 
TIFF  
JPEG  
BMP  
PCX   
PNG  
GIF  
 
 
Database 
 
Please also read the Database section below. 
 
The program support MS Access (JET) and most ODBC compliant databases.  MS 
Access 2000 databases can be created with your MS-Access software.  If you do not 
have MS-Access, you can create the database with the DB90.exe Database Maker.  
You will find this utility in the Infothek Docudex folder (probably in the C:\Program 
Files\Informatik Inc\Docudex folder).  You do not need a MS Access license to run 
Infothek Docudex.  For a quick the evaluation of the program you can use the 'dummy' 
PLAYDB database included in program’s folder.  Please note that the PlayDB is 
‘oversimplified’ with only four index fields; your real database can have up to 30 index 
fields. 
 
Finally, we cannot stress enough that this program is a comprehensive document 
imaging system with many functions and features, and you probably will need 
assistance.  If you have any questions or suggestions, please do not hesitate to ask for 
support.  Not all functions and shortcuts are fully covered in this user documentation.  
 
If you run the program on Windows 95/98/ME, make sure that you have the MDAC and 
JET engine 4.0 installed.   
 
This section is just an introduction to the database; see more information in the 
Database section below. 
 
 
Scanning Documents 
 
Please read section on scanning below. 
 
Infothek Docudex includes a basic scanning module (Scanning – Limited from File 
menu).  For volume scanning you are advised to use a more powerful and versatile 
Infothek Scan software.  If you are using Docudex version 10.20 or higher the trial 
version of the Infothek Scan is included and can be run from the File menu (Scanning – 
Complete).  If you are using an older version, the Infothek Scan can be downloaded.  
Please contact Support.  Please note that Infothek Scan is not integrated; it is a separate 
program with its own User Guide, and a separate license is required, except for site 
licenses.  With Infothek Scan you scan all your documents first, then you open Infothek 
Docudex and create the index for the scanned documents. 
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Licensing 
 
Please read the README.TXT file. 
 
 
Warranties, Disclaimer 
 
Before you use this software please read important disclaimer information in the 
README.TXT file. This program is supplied AS IS without any warranties or liability. 
 
 
 
To obtain technical support 
 
Please go online to www.informatik.com/support.html for contact information.  
 
Infothek is a Registered Trademark of Informatik Inc. 
Docuthek and Docudex are trademarks of Informatik Inc. 
© 1994-2005 Joseph Buchmann.  All rights reserved.  Informatik Inc. 
Please visit www.informatik.com 
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Tutorial, Walk-thru  
 
When you first read this tutorial you probably have not created an index database and 
have not scanned in any documents.   No problem.  The downloaded software includes 
a few sample TIFF files and a dummy PLAYDB database.  Please note that the Playdb 
is ‘oversimplified’ with only four index fields; your real database can have up to 30 index 
fields.  
 
(To create your own database, use MS Access or use the db90.exe database creation 
tool. Infothek Docudex is also compatible with virtually all ODBC databases.) 
 
•  Start up Infothek Docudex.  Initially, Docudex should start up with the ‘play database’ 

(playdb.mdb).  If the ‘Select Database’ window appears, select the PlayDB database 
yourself.  You will find the PlayDB database in the same folder as the Infothek 
Docudex program files, probably in C:\Program Files\Informatik Inc\Docudex.  

 
•  (Alternatively, from the File menu, select Database Selection.) 
 
•  In the Database Selection window, inside the MS Access Databases frame, click on 

the Database Selection button and specify the drive and the directory (folder) where 
you have installed Infothek (probably in C:\Program Files\Informatik Inc\Docudex).  
Note that the Playdb is over-simplified; the real databases can have up to 30 fields. 

 
•  From the Database list, select PLAYDB.MDB. 
 
•  From the Table list, select PlayTable (it may already be selected). 
 
•  Click on OK button. 
 
•  Click on the Open Images button (camera, first button in the toolbar). 
 
•  Select the Infothek Docudex directory (folder), for this test probable the C:\Program 

Files\Informatik Inc\Docudex folder. 
 
•  In the File Types list, select TIFF Files.  You now see the Sample Tiff files listed. 
 
•  Select the Sample1.tif file and click on the OK button. 
 
•  The Sample1.tif file is displayed. 
 
•  We will now index the image.  Click on the Indexing button (pencil, second button in 

the toolbar). 
 
•  The Indexing window is displayed with the file name already defaulted.  The indexing 

window is displayed in the upper-right corner of the screen.  You should not move it; 
otherwise it may cover up error messages and the system might appear ‘frozen’.  If 
that happens, press the ‘Enter’ key. 
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•  Type a number in the Account Number field (this field is assigned a numeric data 
type, so it must be a number).  Type Miller John in the Customer Name field, 
and enter some valid date in the Date field.  There are many shortcuts for the 
indexing process, and you can make the process virtually automatic.  Later, please 
review the Indexing section in this user guide. 

 
•  Click on the Checkmark/Plus button in the Indexing window (the button with the 

checkmark AND the plus symbol).  This updates the database and opens the next 
image. 

 
•  The next image is displayed.  If the Indexing window is not already displayed, click 

on the Indexing button (pencil).  Click on the Indexing window if it does not already 
have the focus.   

 
•  In the Indexing window, enter some different data.  Make the Customer Name field 

Millhouse Robert. 
 
•  Click on the Checkmark/Plus button again.  The database is updated and the next 

image is displayed. 
 
•  Click on the Indexing button (pencil) again, or simply click on the Indexing window so 

that it get the focus, and fill in the indexing information in the Indexing window.  Enter 
some text. 

 
•  Click on the Checkmark/Plus button for updating. 
 
•  Next we will do a Query.  (You can close the Indexing window by clicking on the x-

button in the upper right corner of the Indexing window.)   
 
•  Click on the Query button (2 question marks, third button in the toolbar). 
 
•  The Query, Search window is displayed. 
 
•  From the first Search Field list, select ‘Customer’. 
 
•  From the Search Operator list, select STARTS WITH. 
 
•  In the Filter field, type Mill (i.e. the first four characters of Millhouse. 
 
•  Click on the Execute Search button in the Query window (green spot). 
 
•  The system found all records that match the query, i.e. Miller and Millhouse. 
 
•  Double-click on the Miller record.  (Alternatively you can display the images as 

thumbnails, then view the full image by clicking on the thumbnail.  The thumbnails 
display can be selected from Image List in the File menu.) 

 
•  The Miller image file is displayed. 
 
*** END OF TUTORIAL *** 
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This tutorial covers a very tiny portion of the program’s capabilities.  You now should go 
through each of the online help topics.  The program is very comprehensive.  Special 
areas of interest are: 
 
Scanning 
Image List (thumbnails) 
Window panning 
Notes (annotations) 
Cropping 
Display sizes 
Zooming  
Multi-page handling 
Indexing shortcuts 
 
  ….  and more 
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Database 
 
Infothek Docudex requires the MDAC and JET Engine 4.0 files.  If you get an error 
message when opening a database, you may be missing the MDAC and/or JET Engine 
4.0 files. Both are free downloads from the Microsoft web site. 
 
If your computer runs Windows XP or if you have Microsoft Access installed, then you 
already have the MDAC and JET Engine files.  If your computer runs on the Windows 
95, 98 or ME platform, you may not have these files. To download go to 
http://msdn.microsoft.com/data/downloads/default.aspx and download the lowest 
available version of MDAC.  If you download MDAC 2.8 then you must also download 
the JET Engine 4.0 (since MDAC 2.8 no longer includes the JET engine 4.0).  
 
 
The program requires a database for the indexing of images.  Supported databases 
include Microsoft Access and most ODBC compatible databases.  Included in the 
program files is a ‘practice’ database in the MS Access 2000 format, called Playdb.  You 
should create your own database to suite your exact indexing requirement.  A MS 
Access 2000 database can be created with either the MS Access software or, if you do 
not have the MS Access software you can create a simple MS Access compatible 
database with the db90.exe database creation utility.  You will find this utility in the 
Infothek Docudex folder (probably in the C:\Program Files\Informatik\Docudex folder).  
You do not need the MS Access software license, although, if you plan do run complex 
database management functions, database restructuring, compaction, database repairs, 
etc. you will need the MS Access software.  Please note that the Playdb is 
‘oversimplified’ with only four index fields; your real database can have up to 30 index 
fields. 
 
When creating the database structure bear in mind that one field (ideally the last field) 
must (should) be named Imagefile.  This field must be sufficiently large to hold the 
pointer to the image file (full path name of the image file).  Also, for efficient searching it 
is recommended that the searchable fields be indexed fields.  Properly planned indexes 
will significantly improve the search performance.  Carefully specify the data types of the 
database fields.  For example Date fields should be designated as DATE data type.  
Ensure that the field size is adequate for all your data input. The database table can 
have up to 30 searchable index fields.   
 
Also, it is highly recommended that you break the database into manageable sub-
directories, each directory small enough so that the image files can fit on a CD should 
you decide later to transfer the image files from the hard drive to CDs.  The sub-
directories should have meaningful names, such as 2004Q1 for example for files of the 
first quarter of the year 2004.  
 
For the purpose of system testing, the system includes an over-simplified database 
called PLAYDB.MDB.  If the file is missing and you wish to obtain a new file you can 
download it from www.informatik.com/infothek.html.  Please note that the Playdb is 
rather ‘oversimplified’ with only four index fields; your real database can have up to 30 
index fields. 
 
You can add special edit options, such as: 
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•  Default Entries (fixed text or the current date) 
•  Imports from other databases 
•  Abbreviations (for quick input) 
•  Compulsory Tag (to specify that the field must be entered) 
•  Format Mask (to verify a predetermined format) 
•  Match (entry must match one of the pre-defined strings) 
•  Skip Tag (to skip a field when pressing the tab key) 
•  Popup list for a selection of entries 
 

 
The Default tag populates the field with a specific initial entry (can be the current date or 
fixed text).   The Abbreviation tag activates a list of field-specific abbreviations.  The 
abbreviation is looked up and invoked when you enter a space. The Pattern tag verifies 
that an entry matches a certain specified pattern. The Match tag verifies that an entry 
matches one of several listed values (numbers of words).  If a Compulsory tag is 
specified, the record can only be posted if a field entry exists.  A Skip tag causes the 
field to be skipped when you press the Tab or Enter keys.  The Popup option displays a 
popup list of entries for selection.   
 
For information and instructions on setting up these options, please read the Database 
Setup at the end of this user guide. 
 
Once you have built a database structure, it can be selected from Database Selection in 
the File menu.  Many users also create a UDL file.  The UDL file is a Microsoft concept 
that simplifies the access to databases.  Generally, a UDL file is needed for all ODBC 
databases and for MS Access databases that are protected by passwords.  For more 
information about creating a UDL file see Universal Data Link File (.udl) section in the 
Database Setup section at the end of this user guide.  Once selected in the Database 
Selection, the database name will be saved as the default database. 
 
•  From the File menu select Database Selection. 
•  The Database Selection window is opened. 
•  For MS Access databases and databases that have a UDL file click on the Select 

Database button, locate the database file (.mdb file or .udl file) and specify the Table.  
Databases that have been defined in Database Setup (see section below), including 
ODBC databases, must be selected from the ‘Defined Databases’ list.  Defined 
Databases can also be easily selected from the Databases pull-down list in the main 
window.   

•  Click on the OK button. 
 
When selecting a database and table, the system will look for the database field that 
contains the link to the image files, normally called IMAGEFILE. If the field is missing, or 
not readily known to the system, you are prompted to enter the appropriate field name.  
For simplicity it is suggested that you always use the name ‘Imagefile’ for the database 
field that contains the link to the image file. 
 
If you need to make global changes to the entries in the Database, for example to 
change the driver or folder of the image file location, please use the Global Replace in 
the Index window (Edit menu). 
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The database is selected from ‘Database Selection’ in the File menu.  Once selected, it 
becomes the default database.  Click on the Database Selection button and locate the 
.UDL or .MDB file.  If a database has been defined, it is be listed in the ‘Defined 
Databases’ pull-down list for quick selection, or select the database from the pull-down 
list in the main window.  To define a database, open the database, then, select the 
Indexing window, and from the File menu, choose ‘Database Setup’.  For more 
information, please read the Database Setup section below. 
 
Defined databases (only) are shown in the Database pull-down list on the main page 
and can be opened by clicking a listed database. 
 
 
ODBC databases 
 
If you use an ODBC database (instead of the MS Access), you should create a UDL 
(Universal Database Link File).  UDL files define the connection string needed to open 
the database.  Please read the Universal Data Link file section in the Database Setup 
section below.   
 
 
Record ID 
 
If your database includes an auto-incrementing Record ID you must specify a default 
entry of [Ex] for that field.  See Database Setup section below.  The [Ex] will cause the 
system to send a blank entry to the database, which will then insert the Record ID.  Note 
that your database must be setup for the Record ID when the database is created with 
the database software, e.g. Microsoft Access; the simplified Database Creation utility 
has no option for the Record ID.  Please read the Database Setup section below for 
instructions on how to specify default entries. 
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Scanning, Acquisition     
 
Infothek Docudex includes a basic scanning module (Scanning – Limited from File 
menu).  For volume scanning you are advised to use a more powerful and versatile 
Infothek Scan software.  If you are using Docudex version 10.20 or higher the trial 
version of the Infothek Scan is included and can be run from the File menu (Scanning – 
Complete).  If you are using an older version, the Infothek Scan can be downloaded.  
Please contact Support.  Please note that Infothek Scan is not integrated; it is a separate 
program with its own User Guide, and a separate license is required, except for site 
licenses.  With Infothek Scan you scan all your documents first, then you open Infothek 
Docudex and create the index for the scanned documents. 
 
 
This section covers only the scanning operations of the simple, integrated scanning 
functions of Infothek Docudex; for scanning with Infothek Scan (Scanning – Complete) 
please read the separate User Guide of Infothek Scan.  Scanning with the simple, 
integrated scanning software is suitable for occasional or low-volume scanning; for large 
volume scanning you should always use Infothek Scan. 
 
The scanning options are accessible from the File menu. 
 
The scanning functions require a TWAIN-compliant scanner.  Make sure that you have 
the latest TWAIN driver supplied by the scanner manufacturer. 
 
It is suggested that you scan the documents into a sub-folder of the ultimate folder.  The 
sub-older should be called ‘Pending’.  When you later index, the file will automatically be 
moved up to the parent folder (i.e. the ultimate folder).  So, when the Pending folder is 
empty you are assured that all documents have been indexed.  See also section on 
Pending folder below. 
 
If you scan with Infothek Scan, the current file name can be transferred (poked) to the 
Infothek Scan application by choosing the Poke File Name to Scan option in the File 
menu (Shift+F8). 
 
 
Scan (Single) 
 
This option is for scanning a single sheet with a flatbed scanner. 
 
•  Power up your scanner. 
 
•  From the File menu of the image display window, select Scan (Single). 
 
•  The Twain interface is displayed. 
 
•  Specify the settings, like resolution, monochrome/color, size, etc. 
 
•  Confirm. 
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•  It may take some time before the scanner device warms up. 
 
•  When the scan is finished, the image is displayed.  Select Save As (Page Only) 

from the File menu.  The Save As (Page) window is displayed.  If you scanned and 
saved an image before, the previous file name is displayed in the Filename field, 
otherwise the Filename field will be blank.  It is suggested that you use numeric file 
names, such as abc0001.tif or 123456.tif.  If the file name includes a numeric 
element, the file name can be incremented with the Plus (+) button.  If the file name 
shown in the Filename field is correct or if the field is blank, click on Save Page to 
save the image to a new file, or click on Append Page to append the file to an 
existing TIFF file.  If you want to save to a file other than the file shown in the 
Filename field, select the ‘Browse+Save Page’ or ‘Browse+Append’ Page button 
instead.  Be careful not to append to a file format that does not support multiple 
pages.  Only TIFF files support multiple pages.  Use with great care.  If not used 
correctly, good files might be overwritten and lost.  Always make sure that you have 
a good backup of all files that are being affected.     

 
The image can be saved in various formats.  Just give the file name the appropriate 
extension and the system will save it in the correct format.  For example to save a file 
as a JPEG, give it a name with a .jpg extension, for example somefile.jpg.  Other 
extensions are:  tif, bmp, png, pcx, gif, etc. 
 
If you save the file in the JPEG format, you should also specify the JPEG Quality (2-
99).  For color images a JPEG quality factor of 75 is recommended.  For black and 
white images a quality factor of 40 is adequate.   
 

 
Scan (ADF Multi) 
 
This option is for scanning with an Automatic Document Feeder (ADF) and creating a 
new multi-page TIFF file.    
 

•  Power up your scanner. 
 

•  Click on Scan (ADF-Multi) in the File menu.   
 

•  The Save As Dialog will be displayed.  Select or specify a file name.  If the file 
already exists, it will be overwritten.  It is suggested that you use numeric file 
names, such as 12345678.tif or abc00001.tif.  If the file name includes a number, 
the file name will be incremented automatically for the next scan.  Press on OK 
button. 

 
•  The Twain interface is displayed. 

 
•  Specify the settings, like resolution, monochrome/color, size, etc 
 
•  Confirm 

 
•  Wait for the scanner device to warm up. 
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•  After scanning the batch in the tray, the last page will be displayed.  You can 
open the entire multi-page document by clicking on the Open Scanned File. Do 
not save the file again; it has already been saved. 

 
Note that with ADF scanning the file is now already saved.  Unlike the Scan (Single) 
option, Scan (ADF-Multi) prompts you to enter the file name before you scan.   
 
 
Scan (ADF Multi) Append 
 
This option is similar to Scan (ADF-Multi), it scans all documents in the Automatic 
Document Feeder (ADF) and appends it to an existing TIFF file.  If the specified file does 
not exist, it will create a new file.  Make sure that you only append to file formats that 
support multiple pages.  Only TIFF files support multiple pages.  If you append to a file 
that does not support multiple pages, the file may be overwritten and lost. 
 
 
Pending Folder 
 
It is suggested that you scan the documents into a sub-folder of the ultimate folder.  The 
sub-folder must be called ‘Pending’.  When you index later, the file will automatically be 
moved up to the parent of the ‘Pending’ folder (i.e. the ultimate folder).  For example, if 
the documents are scanned into the c:\doc123\Pending\ folder, when you confirm the 
index entry, the image files will be moved to the parent folder, i.e. to c:\doc123.  The 
‘Pending’ folder can have sub-folders.  So, files in c:\archive\pending\invoices will be 
moved to the c:\archive folder.   When the Pending folder is empty you are assured that 
all documents have been indexed.   
 
 
Print Scanned Document 
 
The scanned document can be printed.  Select the File menu and choose Print.  If the 
print size is incorrect you need to change Print Scale in the Print window. 
 
See also the Print section below. 
 
 
Combine Files 
 
The Combine Files option (in the Files menu) provides an easy method of combining 
single-page TIFF files into one multi-page TIFF file.  Open a single-page image file and 
select the Combine Files option from the File menu.  In the displayed Combine Files 
window specify the destination folder and file name and click on the Save button.  The 
displayed image will be appended to the specified destination file and the next image is 
displayed.  
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View and Change Images 
 
An image file can be opened from the File menu or, more likely, you will find and open 
an image file by way of a query. 
 
Multipage TIFF files also show all pages in scrollable thumbnails display.  The 
thumbnails can be closed (hidden) by clicking the checkbox at the top of the thumbnails 
display.  To re-display the thumbnails (if you have removed them), choose Thumbnails 
from the View menu.   
 
 
Open an image file from the File menu  
 
•  From the file menu, choose Open Image File, or click on the Imaging button 

(camera).  The Open File dialog is displayed. 
 
•  Select the drive, folder and file name.  The image is displayed. 
 
•  To open the next sequential file in the folder, click on the Open – Next Image button 

(yellow file with red arrow).  To go back, click on the Open - Prior Image button.  
Instead of clicking on the buttons you can select the equivalent functions from the 
File menu (with optional shortcut keys). 

 
•  If the image is a multi-page file, click on the thumbnail image of the page or use the 

page navigation buttons to view the pages.  Please read the Multiple Page Image 
Files section below. 

 
 
Open an image via a Query 
 
•  Run a query.  Please read the section on Query for instructions. 
 
•  The query will list all files that match the query criteria.  Each row in the query table 

lists one file with selected detail.  
 
•  Select a row and double-click on any cell and the image file is displayed.  The data in 

the cell that you clicked will become the header for the displayed image.  Instead of 
double-clicking on the cell, you can select the cell and click on the Imaging button 
(camera).  

 
•  To open the next sequential file in the query table, click on the Open – Next Image 

(Query) button (blue magnifying glass with red arrow).  To go back, click on the Open 
- Prior Image (Query) button.  Instead of clicking on the buttons you can select the 
equivalent functions from the File menu (with optional shortcut keys). 

 
 
If the database points to an invalid driver letter (for example if the image files are on a 
CD), specify the Substitute Drive from the File menu.  The substitute drive (and 
network drives) can also be defaulted in Setup. 
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Open an image from the Indexing window 
 
You can also open an image while working in the Indexing window.  Typically, you would 
first run a search in the Indexing window, then optionally, navigate to the desired record 
(with the Next and Prior arrow buttons in the Indexing window). To open the image file 
for the current record click on the View Image button (camera) in the Indexing window, 
or select the function from the File menu.  To open the next sequential image file you 
must select the next record, then click on the View Image button again; do not use the 
navigation buttons in the general toolbar. 
 
 
View Options 
 
 
Thumbnails 
 
See Multi-page Images section below. 
 
 
Multiple Display 
 
When you open an image it is always displayed in the active image window. If you want 
to display the image in a new and separate window, select New Image Window from the 
File menu in the Image window before you select the new image.  For viewing images 
from the query window you can opt for individual windows by checking the Automatic 
New Frame check box in Setup.  Please also read the Setup section. 
 
This option should not be used for multi-page files.  If you have several windows open, 
you can arrange the windows with options from the Windows menu (Tile, Cascade).  
You can also clear and close all windows with the Clear Windows option in the Windows 
menu. 
 
 
Pan Window (Panning) 
 
For very large images you can use panning to view a particular area of the image. When 
panning is active, the full image is represented in a miniature window.  A small rectangle 
inside the miniature picture represents the area of the image that is displayed.  With your 
mouse, move the small rectangle to the area that you wish to see.   
 
For panning, the setting in the View menu must be Actual Size or Fit-to-Width. 
 
The Pan Window can be turned off in he View menu. 
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Sizing 
 
The displayed image can be resized: 
 
•  Full Size 
•  Fit-to-Width 
•  Fit-in-Window 
•  Magnification Factor 
 
Click on the Full Size button in the toolbar or select the option in the View menu.  Actual 
Size displays the image in its natural state, adjusted for the zoom and magnification 
factor.  You may need to use the horizontal and vertical scroll bars to see the entire 
image, or you can use the Window Panning function. The Magnification Factor is used to 
customize the size of the image.  The selection Factor can be saved as a default setting 
in Setup. 
 
Click on the Fit-to-Width button in the toolbar or select the option in the View menu.  Fit-
to-Width resizes the image so that the width fits the window.  This option is most suitable 
and recommended for viewing letter-size and legal-size documents.  You may need to 
use the vertical scroll bars to see the lower part of the image. The selection Factor can 
be saved as a default setting in Setup. 
 
Click on the Fit-in-Window button in the toolbar or select the option in the View menu.  
Fit-in-Window resizes the image so that the entire image fits inside the window.  This 
option is suitable for small images or if you have a large display screen. The selection 
Factor can be saved as a default setting in Setup. 
 
The window size and state is set in the Setup.  See Setup section. 
 
 
Magnification Factor 
 
The Magnification Factor is used to customize the size of the image. The selection 
Factor can be saved as a default setting in Setup. 
 
 
Zooming 
 
You can zoom in and zoom out with a click on the Zoom button (magnifying glass with 
plus and minus signs), or by choosing the zoom option from the View menu.  Typically, 
the zoom increases the size by 25% but the zoom factor can be changed in the Setup.   
 
 
Zoom Area 
 
You can also select a Zoom Area with a click on the Zoom Area button or from the View 
menu.  After selecting the Zoom Area option, move the mouse while holding down the 
left mouse button and outline a rectangle, then release the mouse. 
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Multi-page Images     
 
The TIFF file formats support multi-page files (one file consisting of several pages).  
When you open a multi-page file, the thumbnails of the pages are displayed on the 
right-hand side of the screen.  Click on a thumbnail to open the respective page.  
Several useful navigational buttons are also available in the Pages menu and sidebar.  
These buttons allow you to move to the first, next, prior and last page of the current file.  
To open a specific page, type a valid page number in the page number box (between the 
page navigation buttons in the toolbar), and press Enter.  The page navigation functions 
are also available from the Pages menu.  The number of pages in the multi-page TIFF 
file are shown in status bar at the bottom of the window. 
 
If your TIFF files have a very large number of pages, in order to improve performance, 
you may want to limit the number of thumbnails.  The default limit of thumbnails is 300. 
The number of thumbnails can be changed in Setup.  If the number of thumbnails is set 
to zero, the thumbnail display is disabled. 
 
The thumbnails can be closed (hidden) by clicking the checkbox at the top of the 
thumbnails display.  To re-display the thumbnails (if you have removed them), choose 
Thumbnails from the View menu.  To refresh the thumbnails, choose Thumbnails 
Refresh from the View menu. 
 
You can also opt to rotate all pages of a multi-page file.  From the Pages menu, select 
Perma-Rotate.  For more information, read the View Image section. 
 
The currently displayed image can be appended, inserted to another TIFF file or can 
replace a page of another TIFF file: 
 

 
Append Page: 

 
•  From the Pages menu, select ‘Append this Page to’ 
•  In the Dialog window, specify the file to which you want to append the 

currently displayed image.  The file must be a TIFF file. 
•  Click on OK button. 

 
 

Insert Page: 
  

•  From the Pages menu, select ‘Insert this Page to’ 
•  In the Dialog window, specify the file in which you want to insert the currently 

displayed image.  The file must be a TIFF file. 
•  Click on OK button. 
•  In the pop-up window, specify the page in front of which you want to insert 

the currently displayed image. 
•  Click on OK button. 
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Replace Page: 
 

•  From the Pages menu, select ‘Replace this Page from’ 
•  In the Dialog window, specify the file in which you want to replace a page.  

The file must be a TIFF file. 
•  Click on OK button. 
•  In the pop-up window, specify the page which you want to replace with the 

currently displayed image. 
•  Click on OK button. 

 
 
Delete a Page 
 

To delete a page, choose the Delete Page function from the Pages menu.  After 
deleting a page, you should re-open the image file.  Use the Delete function 
carefully, the delete action cannot be undone. 

 
 

Re-Arrange Pages  
 
To re-arrange the sequence of pages, or to segregate pages from a multi-page file and 
create a new file, use the Re-arrange Pages option from the Pages menu.  Pagination 
allows you to re-arrange and intermingle pages from three files.  Before you use this 
function, familiarize yourself with its capabilities and limitations and make sure that you 
have a good backup of the files that are affected. 
 
By default the current file is displayed in List A.  To open other files, click on the Open 
File button, or select option from File menu. 
 
Select the pages that you wish to relocate or delete.  Click on a single page to select 
one page; to select a range of pages, click on first and last page of a range whiled 
holding down the SHIFT key; to select several pages (contiguous or non-contiguous), 
click on the pages while holding down the CTRL key.   
 
To move the highlighted pages, press down the left mouse button on the yellow ‘Drag’ 
marker, drag the marker to the destination position, and release the mouse button.  The 
location spot must be either between two existing pages, or in front of the first page, at 
the end of the last page, or anywhere on an unused list.  When moving pages within the 
same lit, only one page can be moved at one time. 
The last dragging operation can be cancelled.  The undo function is in the Edit menu. 
 
Select the pages that you wish to rotate, one or several (see Select Pages section 
above).  From the Pages menu, choose a Rotate function.  Confirm.   
 
Select the pages that you wish to delete, one or several (see Select Pages section 
above).  From the Pages menu, choose Delete Selected Pages.  Confirm.  The Delete 
action cannot be undone.  Note that the delete function does not remove the pages from 
the original file until you save the changes. 
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As you mouse moves over a page, the image is displayed magnified in the viewer.  The 
viewer can be disabled in the View menu. 
 
The above functions are reflected only in the thumbnail display lists.  The actual file is 
changed only once you choose the option. 
 
A click on Save (All Pages) button saves all the pages displayed in the list.  Generally, 
if formats are supported, the pages are saved in their original compression and color 
depth.  The Tag 270 values are preserved, but other special tags are generally lost. 
 
Check the ‘Append File’ if the pages are to be appended to an existing file. 
 
The Clear functions (button or selection in Options menu) clears the screen, without 
saving the changes. 
 
 

Indexing, Database Entries 
 
A 17-inch or larger monitor is recommended for indexing.  If you have a smaller monitor, 
to increase the viewing area, you should set the resolution of the monitor as high as 
possible. 
 
The indexing window is displayed in the upper-right corner of the screen.  You should 
not move it; otherwise it may cover up error messages and the system might appear 
‘frozen’.  If that happens, press the ‘Enter’ key. 
 
There are many shortcuts for the indexing process, and you can make the process 
virtually automatic.  Please also review the Semi-Automated Indexing section 
below. 
 
Each image file should be indexed in the index database so that it can be located 
instantly by simply keying in known keywords. 
 
It is generally suggested that you scan all the days’ documents in a batch mode and only 
index after all documents are scanned.  Please read the section on Scanning for more 
information. 
 
The program has many features to make the indexing easier and faster.  For example, 
an entry from the previous record can be repeated by simply pressing Function Key 3, or 
you can create master records that can be cloned with a single key press.  If on of the 
fields is (for example) to show the document type, you may want to scan all documents 
of the same type into one special sub-folder and let the indexing default the field entry to 
the folder name.  This and other shortcuts can be formulated in the Database Setup; see 
section below, or contact Informatik. 
 
Before you can index, you need a valid database.  If you have not access to an existing 
database or have not yet created a database, please read about it in the Database 
section.  The Database section tells you how to structure the database and how to add 
various editing options. 
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Generally, you create one index record for each scanned document, but it need not be 
so; you can create several indexes for one document or you can have indexes without 
documents (un-attached index records). 
 
The entered data is validated at three levels: Some basic validation (like validating that a 
number field has a valid number or a date filed has a valid date) is done when you move 
to the next entry field.  Additional verification is done at a field level for edit specifications 
that you have in Database Setup (see Database Setup section below).  Finally, the 
database engine performs a final validation before the record is created or amended. 
 
Here is a step-by-step procedure to index documents that have previously been 
scanned.  If you wish to create un-attached records (not indexed to a scanned 
document), then simply by-pass the first several steps. 
 
•  Start up Infothek Docudex.  If you are using a trial version, you will see the Licensing 

window; for now simply click on the Continue button.  When Infothek starts up it will 
display a blank window that will later hold the document image. If you have not 
previously selected the database, select if from the File menu (Database Selection).  
Once selected, the database will be defaulted until changed.   

 
•  From the File menu, select Open Image File.  From the Open File dialog box, select 

the image file that you wish to open and index (select drive, folder and file).   Click on 
the OK button and the image will is displayed. 

 
•  You can navigate to the next or prior image file (alphabetical order) by clicking on the 

Open Next Image and Open Prior Image button in the toolbar (the buttons with the 
arrow and yellow file folder, not the buttons with the arrows and magnifying glasses).  
The same navigation functions are also available from the File menu with shortcut 
keys.  If the image file is a multi-page file you can navigate thru the pages with the 
Pages button in the toolbar (the cluster of arrow buttons on the left side of the 
toolbar) or choose an option from the Pages menu.  To move to a specific page of a 
multi-page file, just type in the page number in the small box next to the Pages 
buttons.  For other viewing functions, such as zooming, rotation, etc. please read the 
Image Viewing section.  

 
•  To open the Indexing window, click on the Indexing button (pencil) or choose the 

Indexing option from the File menu.  The Indexing window is displayed showing 
blank entry fields.   If you have specified a default entry (see Database section), the 
default entry will appear in the field.  The Imagefile field always shows the file path of 
the currently displayed image.  If a record is already open you must click on the 
Clear button (clr) before you create a new record.  Click on the Indexing window to 
refresh the data. 

 
•  In the Indexing window, enter the various fields.  You can move to the next field by 

pressing either the Enter key or the Tab key.  To repeat the entry from the previously 
record, press Function Key 3  (or choose the equivalent function from the Edit menu.  
If a certain field should always be skipped, you can specify so in Database Setup 
(see Database Setup section below). 
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If the entry fields are white the system is ready for a NEW record; if the field is gray, an 
existing record is displayed and you can edit (modify) that record.  If the field is gray and 
you want to create a new record you must click on the Clear button  (in the Indexing 
window) first. 
 
There are several productivity options.  In addition to the Repeat function (F3) you can 
create a Template (from Edit menu), the post the template into a new record (Ctrl + F3).  
If a field includes a numeric item, you can increment the number by 1 unit (Edit menu, 
or Ctrl+I).  Finally, you can set up field-specific abbreviations , default entries and 
pop-up lists (see Database section). 
 
To post the index to the database click on the confirm button (checkmark).  To post the 
entry and immediately display the next image for indexing, click on the Confirm+Next 
button.  Before the record is posted, the system will validate the entries.  Certain entries 
are validated by the database.  You can pre-validate the entries with specifications in 
Database Setup (see Database Setup section).  If a certain field must have an entry, you 
can specify so with a Mandatory tag in Database Setup (see Database Setup section 
below). 
 
After you have posted the record you should click on the Clear button (clr) to ready the 
window for the next record. 
 
You can specify the field that should get the initial focus in the Indexing window.  The 
field of the initial focus can be specified in the Database Setup.  See Database Setup 
below. 
 
If you have a large number of documents with the same layout, you can set up the 
system so that a specified section of the image is displayed, zoomed for easier reading.  
See DocType section immediately below. 
 
 
 
DocType (Document Type) 
 
When navigating though image files while indexing, individually defined document types 
can open a specified rectangle of the image, zoomed in for easy reading.  To set up and 
use the DocType, please follow this procedure: 
 

1. Open an image file. 
2. Click on the Zoom button (in toolbar) and enlarge the image and move the 

scrollbars so that you just see the rectangle that you need for reading the index 
information. 

3. Open the Indexing window. 
4. Select the DocType menu. 
5. Select Set up New Document Type. 
6. In the dialog box, type a meaningful, user-friendly name for the document type. 
7. Click OK button. 
8. Close the Indexing window and reopen it.   

 
Once the document types are setup, simply select it from the DocType menu. 
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Editing, Search 
 
The Indexing window features a simple search function.  Select the field that you wish to 
search and enter the search criteria (leading characters of the search text) and press the 
Search button.  All matched records are displayed.  If there is more than one record, 
navigate to the correct record with the navigation buttons (arrows).  The records so 
displayed are open for editing.  To edit a record, type the changes and click on the 
confirm button. 
 
 
Restore 
 
The Restore function (File menu) restores to current record. 
 
 
Delete 
 
To delete a record, run a search to find the record, then click on the Delete button or 
choose Delete Record from the File menu. 
 
 
View Image 
 
If you wish to see the image associated with the open record, click on the Open Image 
File button (camera) in the Indexing window, or choose Open Image File (Current 
Record) from the File menu. 
 
 
Import, Export 
 
The Import function imports a tab-delimited text file.  The export function exports all the 
records of the database to a tab-delimited text file. 
 
 
Validation 
 
For validation of entries, please read the Database section. 
 
 
Pending Folder 
 
It is suggested that you scan the documents into a sub-folder of the ultimate folder.  The 
sub-folder must be called ‘Pending’.  When you index later, the file will automatically be 
moved up to the parent of the ‘Pending’ folder (i.e. the ultimate folder).  For example, if 
the documents are scanned into the c:\doc123\Pending\ folder, when you confirm the 
index entry, the image files will be moved to the parent folder, i.e. to c:\doc123.  The 
‘Pending’ folder can have sub-folders.  So, files in c:\archive\pending\invoices will be 
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moved to the c:\archive folder.   When the Pending folder is empty you are assured that 
all documents have been indexed.   
 
 
Global Replace 
 
You can globally edit all database entries.  This procedure is useful if you move files 
from the hard disk to CDs and want to change the database entries to reflect the move 
(instead of using the Substitute drive option).  To globally edit index fields, use the 
following procedure (use with care, the global edit cannot be undone). 
 

1. Ensure that you have a good back up of the database file. 
 
2. Open the Indexing window. 

 
 
3. In the Search Field pull-down list, specify the field that you wish to change, type 

in a search parameter to isolate the records that you wish to include (recordset) 
and click on the Search button.   It does not matter if the recordset includes 
records that need not be changed. 

 
4. From the Edit menu, choose Global Replace. 

 
 
5. In the prompt, type in the ‘replace from’ and the ‘replace to’ strings, separated by 

a pipe character.  For example, to replace the driver letter from C:\ to D:\ you 
would type in c:\|d:\.  To replace a folder name you would type in (for 
example) \firstfolder\|\secondfolder\.  Do not use spaces at the 
beginning or at the end of the string; these will be trimmed by the system. 

 
6. Click on Yes.  The system will show you how the first record would be edited.  

Click on Yes o confirm and proceed. 
 
 
Semi-Automated Indexing 
 
Docudex includes many features that will simplify and automate the indexing process.  If 
you use some or all of the features, the indexing task will be much alleviated.  Below is a 
short summary of the features.  For more information please also read the section on 
Database Setup in this user guide.   
 

1. Place the scanned documents in a directory called ‘Pending’, or a subdirectory of 
the ‘Pending’ directory.  A document indexed out of the Pending directory (or a 
sub-directory of a Pending directory) will automatically be moved to the parent 
directory of the Pending directory, and the image link in the for the database 
index is automatically adjusted.  With this feature you always know which files 
have not yet been indexed.  For more information please read the ‘Pending’ 
section in this user guide. 

 



 25

2. Press Function Key 3 (F3) to repeat the field entry from the previous confirmed 
posting.  You can accomplish the same shortcut by using the [COPY] default in 
the Database Setup.  For Database Setup see the Database Setup section in this 
user guide. 

 
3. Press Shift+Ctrl+F3 to create a template, then press Ctrl+F3 to recall and post 

the template.  This feature is useful if most fields have the same entries. 
 

4. In Database Setup create a [DATE] default so that the system date is 
automatically entered.  Or, use [FILE] to extract all or part of the file name, or 
[DIR], [DIR2] to extract the folder names.  [PAGES] will default the entry to the 
number of pages in the multi-page TIFF file.   For more information on these 
options, please see Database Setup below. 

 
5. Infothek Docudex does not support Optical Character Recognition (OCR), but 

you may want to implement a separate OCR program that captures the 
necessary data into a separate database.  The data can then be used as default 
entries when indexing.  See also the Database Setup section in this user guide.  
Or, the OCR program can create a tab-delimited text file.  The text file can then 
be imported into the Docudex database.  The import function is available in the 
File menu of the Indexing window. 

 
For many other settings, please see Database Setup below. 
 
If you work with different databases, you can associate a default directory (for image 
files) to each database.  The default directory for a database is specified in the Database 
Setup.  See Database Setup section below. 
 
You can also specify the field that should get the initial focus in the Indexing window.  
The field of the initial focus can be specified in the Database Setup.  See Database 
Setup below. 
 
 

Query 
 
The program has powerful yet easy-to-use query functions. 
 
Click on the Search button in the toolbar (question marks), or choose Query from the 
File menu.  The Query, Search window opens. 
 
Most query criteria and specifications can be saved so that they become the default for 
the next query.  To save the criteria and specifications, choose Save Settings from the 
File menu.  The entries are saved by Table name.  If you have several databases that 
use the same Table name, you should set up the databases as Defined Databases (see 
Database Setup below). 
 
Specify any (up to three) Search Fields and Search Operators.  In the Filter box (with the 
blinking insertion point), type in the search criteria.  From the list box on your right, select 
all the fields that you want listed in the search report.  Drag the cursor over the selected 
fields, or click on the selected fields while holding down the Ctrl key (to change the field 
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sequence, see the section below).  If necessary change the Boolean value (And, Or) for 
the second and search field.  Optionally, specify the Sort Order.  The Search Operators 
are described more fully below. 
 
The AND/OR operators are analyzed in the following sequence: 
(Field1 AND/OR Filed2) AND/OR Field3 
 
The search specifications can be saved as defaults.  To save the specifications, choose 
Setup, Preferences | Save Setting from the File menu. 
 
Click on the Query button (green spot) or press Function Key 8; the search will be 
executed.  The matched items will be listed in the report below. 
 
To view the image of a record, select the record and click on the Image button (camera), 
or press Function Key 12, or simply double-click on the record.  You can double-click on 
any cell in the row.  The cell name will be used in the caption of the displayed image.  
When in view mode, simply click on the Open – Next or Previous Image File button in 
the toolbar (magnifying glass with blue arrow), or select the same functions from the File 
menu. 
 
To view the listed images as thumbnails, choose Image List (Thumbnails) from the File 
menu.  To open the image in full size, simply click on the thumbnail. 
 
To return to the image window(s) without choosing a file from the query table, choose 
the Windows menu and select the image window. 
 
 
Examples: 
 
You want to search the database for the name 'Smith' in the Name Field and for a date 
in 2004 in the Date Field. 
 
In the first Search Field, choose the Name field. 
In the first Search Operator, choose STARTS WITH if the surname is at the beginning, 
otherwise choose INCLUDES). 
In the Filter box, type Smith (or smith) 
 
In the second Search Field, choose the Date field. 
In the second Search Operator, choose IS BETWEEN. 
In the Filter box, type 1/1/04,12/31/04 (note the comma between the two values) 
 
If you wanted to search for Smith, but not for names starting with Smith, like Smithson, 
use the Search Operator IS EXACTLY, instead of STARTS WITH. 
 
If you wanted to search for all persons with names of Madison, Bauer and Mock, you 
would use the Search Operator IS IN.  In the Filter you would type the three names, 
separated by a comma. 
 
Date values can be entered in most common formats, such as 11/15/98, Jan 15,1999, 
etc. 
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Search Operators: 
 
IS EXACTLY 
 

You must enter the exact and complete text that you are searching.  This option 
is generally used only to search short and unique text items such as account 
numbers.  Only exact matches will be located. 
 

STARTS WITH 
 

This is the most versatile search operator.  You need only to enter a few leading 
characters of the search test. 
 

INCLUDES 
 

This operator allows you to search for a text string included in the text field.  For 
example, you can search for ‘John’ in a name field that includes other 
information, such as Miller, John.  Use this option sparingly; the search will be 
slow because the system cannot use the index and it must read each record to 
determine if the search criteria is met. 
 

IS LESS/EQUAL THAN 
 

This operator must only be used for numeric or date fields. 
 

IS MORE/EQUAL THAN 
 

This operator must only be used for numeric or date fields. 
 
IS BETWEEN 
 

This operator must only be used for numeric or date fields.  Place a comma 
between the two values. 
 

IS IN 
 

This function allows you to search for alternate matches.  For example, CA, OH, 
MI will display the records that are California, Ohio or Michigan.  Only exact 
matches are located. 

 
 
Sequence of listed files 
 
To change the sequence of the File List, click on the field that you wish to move, then 
press the Insert key (or press the right mouse button), then enter the new field position.  
For example, if you enter the number 5, the highlighted field will be moved to the fifth 
position. 
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Options 
 
To delete a row in the search table, select the row and press on the Delete key 
(keyboard) or select Hide Row from the File menu. 
 
The text of the search table can be printed or exported.  Individual, marked and all 
image files can be printed from the File menu.  These options can be found in the file 
menu.   
 
To copy the graphics files identified by the search to another folder, choose Copy 
Graphics Files in the file menu.   
 
You can trim the table to a few selected (or un-selected) rows.  To select a row, click on 
the first cell (first cell on the left of each row).  When selected, a check-mark is 
displayed.  To de-select the item, click on the first cell again.  After you have selected 
the rows, choose Trim from the File menu.  The menu options delete all rows that have 
not been marked, or depending on the option, keep all the rows that have been marked.  
This feature is helpful if you need to print the content of the search table, export the 
images or export the data. 
 
 
Other File Types 
 
The system can be set so that non-graphics files listed in the query table, such as  PDF, 
RTF, DOC, TXT, etc. files are displayed by the respective native applications.  To 
enable these various file types, make an appropriate entry in Setup, Preferences. 
 
This option is practical only if you have a large screen.  The document’s native 
application will open behind the document imaging program and you will need to press 
ALT+Tab to move the hidden window to the front.  Alternatively, you should set the 
document imaging program to Normalized (not Maximized), so that you can position it on 
the screen in order to make place for the document’s native window. 
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Save Image 
 
To re-save an in image (same file name) 
 
If you made some changes to the displayed image, such as rotation, inversion, 
despeckling, deskewing, addition of notes (annotations), etc.  and you want to save an 
image to the same file name and same page position proceed as follows: 
 
•  Click on the Save button in the toolbar or select Save from the File menu.  
 
 
To save a file under a different name 
 
To save an existing file under a different name: 
 
•  Open the image file. 
•  Choose Save As from File menu.  Do not click on the Save button in the toolbar.  
 
Whenever an image is open, you can save the current file name to the Windows 
Clipboard and retrieve it later when saving or appending another file.  The ‘Save File 
Name’ option is available in the Edit menu. 
 
 
To save the currently displayed image 
 
•  From the File menu, choose Save As (Page Only).  The Save As (Page) window is 

displayed. 
 
•  If the file name shown in the Filename field is numeric, the file name can be 

incremented with the Plus (+) button.  If the file name shown in the Filename field is 
correct or if the field is blank, click on Save Page to save the image to a new file, or 
click on Append Page to append the file to an existing TIFF file.  If you want to save 
to a file other than the file shown in the Filename field, select the ‘Browse+Save 
Page’ or ‘Browse+Append’ Page button instead.  Be careful not to append to a file 
format that does not support multiple pages.  Only TIFF files support multiple pages.  
Use with great care.  If not used correctly, good files might be overwritten and lost.  
Always make sure that you have a good backup of all files that are being affected.     

 
The image can be saved in various formats.  Just give the file name the appropriate 
extension and the system will save it in the correct format.  For example to save a file 
as a JPEG, give it a name with a .jpg extension, for example somefile.jpg.  Other 
extensions are:  tif, bmp, png, pcx, gif, etc. 
 
If you save the file in the JPEG format, you should also specify the JPEG Quality (2-
99).  For color images a JPEG quality factor of 75 is recommended.  For black and 
white images a quality factor of 40 is adequate.   
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Whenever an image is open, you can save the current file name to the Windows 
Clipboard and retrieve it later when saving or appending another file.  The ‘Save File 
Name’ option is available in the Edit menu. 
 
For Appending, Inserting, Replacing pages of a multi-page Tiff file, see Multi-page 
Images section above. 
 
The Save As dialog defaults to All Files (*.*).  The default can be changed in the General 
Setup (accessible via File menu).  In the File Pattern field enter the file type, for example 
*.tif. 
 
Auto-Index 
 
If you save to a new file or rename a file, the Indexing window will appear automatically 
appear after the file has been saved.  If you prefer the to change the default so that the 
Indexing window is not automatically displayed, check the Auto-Index box in the Setup, 
Preferences window. 
 
 
Auto-Delete of Source File 
 
If the ‘Delete source file after Save’ box is checked, the original source file (the file that is 
currently displayed in the main window) will be deleted after the file has been saved.  For 
security reason, this option is available only if the source file is a single-page file.  The 
box must be checked for each Save operation. 
 
 
Convert File to PDF 
 
The option with PDF attachment requires the TIFF2PDF Command line program 
(available as an option).  For information about the TIFF2PDF option, please visit 
www.informatik.com/tiff2pdf.html.  If you download the Tiff2pdf executable, it must be 
placed in the folder of the Infothek Docudex program files. 
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Printing     
 
•  Select and display the image.  
 
•  From the File menu, choose Print (standard or centered) or click on the Print button 

in the toolbar.  The Print Image window appears. 
 
•  Choose OK. 
 
 
Printing from the Search/Query Window 
 
After you have run a query you can print the listed image files (current file, marked files 
or all files) from the File menu in the Search/Query window. 
 
 
Printing of Scanned Documents 
 
The scanned document (un-saved) can be printed.  Select the File menu and choose 
Print.   
 
 
Printing Multiple Images, Bulk Printing 
 
If you want to print several files, selected files from a folder or entire folders, you should 
use the PrintAll (Bulk Printing) in the File menu in the image window.  To print the files 
listed in the query table, choose Print from the File menu in the query window.  
 
 
Spooler Service 
 
By default, multi-page files are treated as one job (this is important for faxing).  To print 
each page of a multi-page file as a separate print job, un-check ‘Print Spooler’ in the 
Bulk Printing window or make an entry in the private INI file (docu100.ini).  See Setup 
and Preferences section below. 
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Other Options 
 
Image Information 
 
The Image Information in the View menu displays various information about the image, 
such as width, height, compression method, formats, etc., all useful information for the 
technically minded. 
 
 
The following options are available in the Images menu: 
 
 
Add Notes 
 
You can add notes to an image file (or page).  The notes are saved in a tag (Tag 270) 
and do not change the bitmap of the image.  If the Notes are enabled (in Setup), each 
time the image file is opened the notes are displayed in a yellow strip at the top of the 
image.   To add a note, select the Add Notes from the Images menu or click on the 
Notes button in the toolbar.  Simply type in the note, or edit existing text, then save the 
image.  By default, the Notes option is disabled.  You can enable/disable the option in 
Setup. 
 
The Notes can be printed via the default Text Viewer.  Choose Print Notes from File 
menu. 
 
 
Invert Image 
 
The Invert function reverses the colors; black letters on a white background become 
white letters on a white background and vice versa.   
 
 
Rotation 
 
There are four Rotation options available in the Image menu.  The basic rotation options 
are also available from the toolbar.  The user-defined rotation can be undone from the 
Image File. 
 
•  Rotate 90 degrees clockwise 
•  Rotate 180 degrees upside 
•  Rotate 90 degrees counter-clockwise 

•  User-defined rotation. 
 
If you select the Perma-Rotate option in the Pages menu, all the pages are rotated at the 
selected angle.  When you open a new file, the Perma-Rotate is cancelled. 
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Crop 
 
 
With the crop function, a rectangle of the displayed image can be cropped and saved as 
a new file or printed.  Select the Crop function from the Images menu, then while 
pressing the left mouse button, outline the area that you want to crop, then release the 
mouse button.  The cropped image is displayed and can be saved or printed.  After 
cropping you can restore the original image with the Reload Image File option in the File 
menu. 
 
 
Auto-Trim   
 
Auto-Trim removes the white borders.  The operation can be reversed with the Undo 
function. 
 
 
White-out, Black-out 
 
The White-out function allows you to remove a selected rectangle; the Black-out function 
can cover up a selected rectangle.  Select the white-out or black-out function from the 
Images menu, then outline the rectangle that you wish to white-out or black-out with the 
mouse while holding down the left mouse button.  When you release the mouse button 
the selected rectangle will be changed.  The action can be reversed with the Undo 
function.  To cancel the white/black-out mode, double-click on the image or de-select the 
option from the Images menu. 
 
 
The following options can be found in the Edit menu: 
 
 
Copy / Paste Image 
 
The Copy/Paste functions are handled via the Windows clipboard.  Thus you can copy 
and paste images to and from another application.  
 
 
Perma-Rotate 
 
If you select the Perma-Rotate option in the Pages menu, all the pages are rotated at the 
selected angle.  When you open a new file, the Perma-Rotate is cancelled. 
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Convert File to PDF 
 
The option with PDF attachment requires the TIFF2PDF Command line program 
(available as an option).  For information about the TIFF2PDF option, please visit 
www.informatik.com/tiff2pdf.html.  If you download the Tiff2pdf executable, it must be 
placed in the folder of the Infothek Docudex program files. 
 
 
 
E-mail 
 
The viewer can be linked to some E-mail programs.  The email client must be specified 
in the Setup, Preferences.  This option is limited and only works with some email clients. 
 
There are two E-mail options: 
 

•  E-mail with the TIFF attachment 
•  E-mail with a PDF attachment 

 
The option with PDF attachment requires the TIFF2PDF Command line program 
(available as an option).  For information about the TIFF2PDF option, please visit 
www.informatik.com/tiff2pdf.html.  If you download the Tiff2pdf executable, it must be 
placed in the folder of the Infothek Docudex program files.  The E-mail (PDF) option 
creates a temporary PDF file in your system’s designated temporary folder. 
 
Generally, when the E-mail option is invoked, the current file is pasted as an attachment.  
Some E-mail clients only show the attachment if the file name has no embedded spaces. 
 

 
User Login (Program Access and Security) 
 
For information and instructions on the User Login (User Ids and passwords) please 
contact technical support.



 35

Setup and Preferences     
 
To specify the system parameters and the preferences, choose the Setup, Preferences 
from the File menu.  The Setup window is displayed. 
 
After you change the settings, you may need to restart the program for the changes to 
take effect. 
 
 
Image Window – Width, Height 
 
This field specifies the width and height of the image display window (inner window).  If 
the value is between 11 and100, the entry represents a percentage of the screen 
width/height.  If more than 100 it represents the measurement in twips  (1440 twips = 1 
inch; 57 twips = 1 millimeter).  If zero (0), the size of the image window is retained from 
the previous session or previous use. The default values are 0. 
 
 
Master Window - State 
 
This field specifies the state of the master window (Maximized, Normalized).  
 
 
Initial Directory 
 
This field specifies the default directory for the Open Image file dialog window, for 
example c:\images\ 
 
 
ShellExecute 
 
If you enter standard file extension names, Infothek Docudex will open these files with 
the associated native program when selected from the Query table.  For example, if the 
ShellExecute entry includes a reference to ‘pdf’, and if the Query table (Imagefile cell) 
lists a file with a .pdf extension, the file will be opened with the default PDF viewer.  This 
feature should be used for viewing only; it is not practical to index files other than TIFF 
files.  
 
Example of an entry in the ShellExecute field: 
doc pdf txt 
 
 
Email 
 
The Email field specifies the path to the Email client (executable name).  This option 
works only with some email clients. 
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Magnification Factor 
 
If you images are displayed at ‘Actual Size’ you can specify the magnification factor.  A 
typical entry would be 33 for 300x300 resolution images, or 50 for 200x200 resolution 
images. The default entry is 100. 
 
 
Substitution Drive 
 
The path substitution will substitute (by an equal number of characters) the leading 
characters of the path name.  For example, if the Path Substitution is D:\and the query 
shows an image name of c:\mydir\myimage.tf, the system will display the 
d:\mydir\myimage.tif file.  This option is useful and essential if the index database points 
to images in the C:\ drive while the images are stored on a locally inserted CD.  The 
substitution drive can also be changed for the current session from the Disk Drive 
Substitution in the Setup, Preferences in the File menu. 
 
Optionally you can enter a network drive, such as \\xyznet.  The network drive name will 
then replace the 2-digit drive letters.  For example, a fixed file path of 
c:\somedir\somefile.tif can be changed with an entry of \\xyznet to 
\\xyznet\somedir\somefile.tif. 
 
 
File Pattern 
 
The Open Image File and the Save As dialog windows only list the Alll Files (*.*) and the 
TIFF Files (*.tif) as file type filters in the File Type list.  You can add a special filter here.  
For example, if you can make an entry of    *.bmp    to list bitmaps in the File Types list. 
 
 
Zoom Factor 
 
This entry represents the zoom factor.  The default is 25.  When you click on the Zoom-
in or Zoom-Out the image is increased or decreased by the Zoom Factor. 
 
 
Maximum Thumbnails 
 
Enter the maximum number of thumbnails that Infothek Docudex should display.  The 
default is 300.   If you enter a value of 0, then thumbnails will not be displayed.  If your 
TIFF files have a very large number of pages you should consider specifying a 
maximum. 
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Display – Size 
 
Images can be displayed in three sizes:  
 
Fit Width (preferred mode, default) 
Size-to-Fit  
Full Size 
 
When using Full Size, you should specify the Magnification Factor (see above). 
 
 
Notes Color 
 
Select one of the available colors.  The default is Yellow. 
 
 
Open Query at Start-up 
 
If this selection is checked, Infothek Docudex will display the Query window upon start-
up. 
 
 
Automatic New Frame 
 
If this option is checked, images from the query table are opened in new image frames.  
If un-checked, images are displayed in the active window, replacing the currently 
displayed image. 
 
 
Auto-Indexing 
 
If this selection is checked, the Indexing window will be displayed immediately after a 
scanning operation. 
 
 
HKEY_LOCAL_MACHINE 
 
If this checkbox is checked (default), the Windows Registry entries for the Database 
Setup are machine-based, otherwise they are user-based. 
 
 
Print Spooler 
 
To disable the print spooler for printing, make the following entry in the [Setup] section of 
the docu100.ini file.  The INI file can be found with the Infothek Docudex program files 
(probably in the C:\Program Files\Informatik Inc\Docudex folder).  This affects only the 
printing done in the general printing option.  For Bulk Printing, un-check the Print Spooler 
checkbox in the Bulk Printing window. 
 



 38

[Setup]  
Spooler=0 
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Database Setup 
 
General 
 
The following options can be set up for each field of the database table: 
 

•  Popup list 
•  Default entry 
•  Abbreviations (for speed typing) 
•  Pattern and text matching 
•  Flag for mandatory entry 
•  Flag for skipping of field (when using Tab key) 

 
You also must make entries in the database setup  
 

a) If you use passwords for database access, or 
 
b) If you use an ODBC database (in most cases in order to specify the connection 

string). 
 
Proceed as follows to make the entries in the database setup: 

 
1. Select the database (File | Database Selection.  If you have created a UDL file 

for the database (highly recommended, see section below), open the database 
via the UDL file, otherwise open it via the MDB file.  For ODBC databases see 
section below.  If you have previously made entries to the database setup, select 
the database from the ‘Defined Databases’ section. 

 
2. Open the Indexing window. 

 
3. From the File menu of the Indexing window, choose Database Setup.  You can 

also select the option from the Setup/Preferences from the File menu (only if an 
image is open). 

 
4. For new databases, the system prompts you to give a short user-friendly name 

for the database.  The name should be short, meaningful and unique. 
 

5. In the Database Setup window, select the field and make the necessary entries.  
See paragraph below for more detail. 

 
6. Click on OK Save button. 

 
7. You must restart Docudex, then re-select the database from the Defined 

Databases (listed on the right side of the Database Selection window). 
 

 
The Database Setup window is self-explanatory.  Here are some helpful hints. 
 
If a Compulsory tag is specified, the record can only be posted if a field entry exists.   
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A Skip tag causes the field to be skipped when you press the Tab or Enter keys.  
 
The Default tag populates the field with a specific initial (over-writable) entry.  The entry 
can be any string or one of the following keywords (keywords must be capital letters and 
must be encapsulated in square brackets): 
 

[COPY]  
 
Automatically copies the previous entry. 
 
[DATE] 
 
Enters the current date (the date when the record is created).  For formatting and 
parsing options.   
 
The date can be in any format.  If you do not want the default short date format 
(for example 12/31/2006), then add your own formatting code, for example: 
 
[DATE]yyyy:mm:dd  will format to 2006:12:31 
[DATE]yyyymmdd  will format to 20061231 
[DATE]yymm  will format to 0612 
[DATE]yyyy  will format to 2006 
 
You can also use hh for hours, mm for minutes and ss for seconds. 
For short month name (e.g. Feb), use mmm. 
For full month name (e.g. February), use mmmm. 
 
 
[FILE]   
 
Enters the base file name or parsed sections of the file name into the index field.   

 
[FILE] followed by a number allows you to take a section of the file’s base-name 
and post it to an index field.  The syntax is as follows:  A positive number will 
read a number of characters from the left; a negative number will take a number 
of characters from the right.  For example –10 (minus 10) will post the last 10 
characters of the file’s base-name to an index field.  The numbers 999 have a 
special meaning.  A positive number 999 will read all characters of the base-
name starting from the left until a space is encountered.  A negative number 999 
(-999) does the same but starting from the right (end) of the base-name. 
 
If the file name has text strings separated by a specific separator character (for 
example an underscore), then you can copy a particular section.  For example, if 
the file name is ‘aaa-bbb-ccc.tif, an entry in Database Setup of [FILE]-,2 will 
capture ‘bbb (the second section.  Or, if the file name is 111~222~333.tif and the 
setup entry is [FILE]~,3 the third section (333)will be captured. 
 
 
[FILEDATE] 
[FILEDATE] 0 too make the default the creation date of the file. 
[FILEDATE] 1 to make the default the ‘last change’ date of the file. 
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[FILEDATE] 2 to make the default the ‘last access’ date of the file. 
 
Optionally, use the same formatting syntax as for [DATE] above, for example  
[FILEDATE] 0,mmyy 
 
[DIR]  
 
Posts the folder name of the current file in the index field.  This useful feature 
allows you to pre-sort documents.  For example, scan all invoices into a folder 
called ‘Inv’ and let the system automatically post the word ‘Invoice; to an index 
field. 
 
[DIR2]  
 
Posts the parent folder name of the current file in the index field. 
 
 
[Pages]  
 
Posts the number of pages of the current file. 
 
[DB]  
 
This option can be used to read data from another database.  Index fields are 
populated automatically upon initialization.  This function is ideal for importing 
data from an OCR-created database.  For advanced use only.  For instructions 
please see section below. 
 
[DB2]  
 
This option can be used to read data from another database.  Index fields are 
populated when the Import Data option is requested by the user.  For instructions 
please see section below. 
 
[TXT] 
 
This option can be used to import text from a text file (.txt) that has the same 
name as the image file (except the extension).  For example, [TXT]2 will read the 
second line of the text file and copy it into the index field. 
 
[EX]  
to specify the field as a Record ID field.  This will cause the software to pass a 
blank to the database (instead of a zero) and will disable editing by Informatik 
Archiver for that field.  The database can then insert the Record ID.  Record ID 
fields need to be created with the MS Access software; please refer to the MS 
Access user guide. 
 

 
The Abbreviation tag activates a list of field-specific abbreviations.  When indexing, the 
abbreviation is triggered and invoked when you enter a space, i.e. when you enter the 
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abbreviation code (without the explanation mark) followed by pressing of the space bar.  
Enter both a short abbreviation code and the expanded abbreviation text.  The 
abbreviation code typically is a 2-3 character text string.  The list is limited to 
approximately 50 entries (total number of characters cannot exceed 1000). 
 
The Pattern tag verifies that an entry matches a certain specified pattern, for example to 
ensure that the social security number corresponds to a particular format. 
 
The single pattern is entered in the setup specification field with fixed characters and/or 
placeholders, for example: 
 
###-##-#### 
or 
(###) ###-####  
 
The following character placeholders are supported: 
 
# stands for one single numeric characters (0-9). 
? stands for one single character (alpha-numeric). 
* stands for one, zero or several alpha-numeric characters. 
In addition, the pattern can include any fixed characters or spaces. 
 
The Match tag verifies that an entry matches one of several listed values (numbers or 
words).  For example, if the Match list has the following five entries, only field entries that 
exactly match one of these listed items are accepted:   
 
Feet meters inches centimeters millimeters.  
 
The list is limited to approximately 50 entries (total number of characters cannot exceed 
1000). 
 
The Popup displays a popup list of entries when a field gets the focus.  The list is limited 
to approximately 50 entries (total number of characters cannot exceed 1000).  
 
Instead of listing the popup items you can also refer to a text file (.txt), for example 
c:\somedir\mypopup.txt.  To use the Text File method, click on the ‘Select a Text File’ 
button.  The popup text file must list all items, one item per line, for example: 
 
Budweiser 
St Pauli 
Urquell 
Kronenbourg 
Stroh 
... 
 
Copy the Database Setup specifications to other PCs 
 
For special utilities that make the copying of the Database Setup to other computers 
easy, please contact Technical Support. 
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Rename or Delete the Database Setup 
 
The setup for a database can be deleted by pressing the ‘Delete Setup’ button in 
Database Setup.  To change the short name of the database, delete it, then re-create it, 
or change it in the Windows Registry HKEY_LOCAL_MACHINE\ Software\Informatik 
Inc\Infothek (alternatively in the HKEY_CURRENT_USER\…).  Proceed with care. 
 
 
Passwords 
 
(This section refers to passwords for database access only.  For login passwords 
(program access and security), please see Login section.) 
 
Docudex version 7.21 and higher supports passwords for Access 2000 databases. 
(Passwords for ODBC databases have always been supported).  The password for a 
database can be entered in the Connection String, but that is generally unsafe.  Instead 
of specifying the password in the Connection String, add a Prompt placeholder in the 
Connection String, like  
 
Password=[?Prompt:Enter the Password]  
(exact spelling and spacing is important!) 
 
Databases with passwords must be created with MS Access software.  The Docudex 
database creation tool does not support passwords. 
 
To use Docudex with password-protected databases you must first change the 
Connection String in the Database Setup: 
 

1. If you have not already done so, create the Database Setup (see above 
sections).  Once the Database Setup has been done, the given short name of the 
database will appear in the ‘Defined Databases’ section in the ‘Databases 
Selection’ window (File | Databases Selection). 

2. Open the database from the ‘Defined Databases’ section in ‘Database Selection 
(File | Database Selection). 

3. Open the Indexing window. 
4. From the File menu, select Database Setup. 
5. Click on the pull-down list next to the Connection String field, and select the ‘MS 

Access with Password’, for example. 
6. In the prompt enter the path to the MS Access database (.mdb file). 
7. Make any other changes to the Connection String, as necessary. 

 
 
Samples of Connection Strings using passwords: 
 
Connection=Provider = Microsoft.Jet.OLEDB.4.0;Data Source=c:\mydir\mydb.mdb;Jet 
OLEDB:Database Password=[?Prompt:Enter Password] 
 
Connection=Provider = Microsoft.Jet.OLEDB.4.0;Data Source=c:\mydir\mydb.mdb;Jet 
OLEDB:Database Password=pshhxyz 
 
For ODBC databases: 
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(please refer also to the ODBC’s reference manual) 
 
(For ODBC databases, whenever possible, use the Data Link File method to specify the 
Connection String; see section below.  The Data Link File removes the complexity of the 
connection string.) 
 
Connection=Provider = SQLOLEDB.1;Data Source=(local);User ID=sa;Initial 
Catalog=pubs; PWD=pshhxyz 
 
Connection=Provider = SQLOLEDB.1;Data Source=(local);User ID=sa;Initial 
Catalog=pubs; PWD=[?Prompt:Password Please] 
 
You can use the Prompt placeholder for User ID also, for example:  UID=[?Prompt:Enter 
User Id] 
 
Check your database reference manual for exact syntax of the connection string. 
 
 
Use of [DB] and [DB2] default in Database Setup 
 
The purpose of the [DB] and [DB2] default options is to retrieve data from another 
database (Source Database) and to post it to the Infothek Docudex (Main Indexing 
Database).    
 
[DB] and [DB2] both import data into the indexing window, but there are some major 
differences in their use.   
 
[DB] 
 

[DB] imports the records immediately and automatically when the indexing 
window is initialized.  [DB] looks for a record in the Source database that 
matches the entry in the Imagefile field.  The path of image files in the Source 
Database must thus match the image files that you are indexing in Main Indexing 
Database. 
 
The Source Database is typically created by an OCR operation.  The fields of the 
Source Database contain the values retrieved from the image file that need to be 
posted to the Main Indexing Database.  One of the fields in the Source Database 
has the full path to the image file that is being indexed, and data from that Source 
Database is then imported into the indexing window. 
 

[DB2] 
 
[DB2] is a universal import tool.  Any field in the indexing window (not just the Imagefile 
as in [DB]) can serve for the query of records in the Source Database.  The [DB2] import 
is not automatic as it is in the [DB] option.  You type the search value in any of the fields 
in the indexing window and you specifically request the import.  All the fields specified in 
the setup are then populated by the values from the record found in the Source 
Database. 
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Setup of [DB]   
(see below for setup of [DB2]) 
 
The [DB] is made functional as follows: 
 

1. If not already done so, in Database Setup (in File menu of the Indexing window) 
select the Main Indexing Database.  Give the database a user-friendly name.  
From now on, you will open the database with that user-friendly name.  All 
databases with user- friendly names are listed in the pull-down list in ‘Defined 
Databases’ in the Database Selection window. 

 
2.  In the Database Setup window, select the field that you like to set up.  Each field 

needs to be set up separately.   
 

3. In the Default section enter the following text string: 
 

4. [DB]n, where n stands for the ordinal number of the field of the Source 
Database that contains the text to be defaulted.  All ‘n’ values refer to the Source 
Database, not the Main Indexing Database.  For example, [DB] 3 will retrieve the 
value of the third field in the Source Database of the record that matches the 
current image file and posts the value to the Indexing window.   

 
5.  Confirm the entry and optionally select other fields that you like to set up. 

 
6. If not already done so, create an INI file called  XXX.INI where XXX is the user-

friendly name of the database defined in the Database Setup.  For example if the 
user-friendly name of the database is MYDB then the INI file must be called 
MYDB.INI. 

 
The entry in the INI file for [DB] must have 4 lines.   The [DB] set of entries can 
co-exist with the entries of [DB2].  All entries in the INI file refer to the Source 
Database.  Exact spelling is essential; a single misspelled string or name will 
invalidate the operation of [DB]. 
 

•  The first line is a fixed [Setup] header.   
 
•  Database= 

The second line is the full path to the Source Database (or UDL file that 
represents the Source Database).  The file must have an .MDB or an 
.UDL extension.  No other files are accepted.  If the database is not an 
MS Access database (JET database), then you must use a UDL file. 
 

•  Table= 
The third line is the name of the Table of the Source Database. 
 

•  Imagefile= 
The fourth line is the field name in the Source Database that contains the 
path to the image file. 

 
Example of an INI file: 
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[Setup] 
Database=c:\somedir\somedb.udl  (or …\somedb.mdb) 
Table=ImageTable 
Imagefile=Image 

 
7. Place the INI file in the same directory as the archiver software (for example 

same file as the docu100.exe program.  Check the file name of the INI file; make 
sure that it has an .ini extension (not ini.txt). 

 
8. The setup is complete.  Now when you initiate the indexing window the indexing 

fields will be populated automatically with data from the Source Database relating 
to the open image file.   

 
The [DB] option is operational only if the database is selected from the list of ‘Defined 
Databases’ (in Database Selection). 
 
 
Setup of [DB2]   
(see below for setup of [DB]) 
 
The [DB2] is made functional as follows: 
 

1. If not already done so, in Database Setup (in File menu of the Indexing window) 
select the Main Indexing Database.  Give the database a user-friendly name.  
From now on you will open the database with that user-friendly name.  All 
databases with user- friendly names are listed in the pull-down list in ‘Defined 
Databases’ in the Database Selection window. 

 
2.  In the Database Setup window, select the field that you like to set up.  Each field 

needs to be set up separately.   
 

3. In the Default section enter the following text string: 
 

4. [DB2]n, where n stands for the ordinal number of the field of the Source 
Database that contains the text to be defaulted.  All ‘n’ values refer to the Source 
Database, not the Main Indexing Database.  For example, [DB2] 3 will retrieve 
the value of the third field in the Source Database of the record that matches the 
import lookup and posts the value to the Indexing window.   

 
5.  Confirm the entry and optionally select other fields that you like to set up. 

 
6. If not already done so, create an INI file called  XXX.INI where XXX is the user-

friendly name of the database defined in the Database Setup.  For example if the 
user-friendly name of the database is MYDB then the INI file must be called 
MYDB.INI. 

 
The entry in the INI file for [DB2] must have 4 lines, (plus two optional lines).    
The [DB2] set of entries can co-exist with the entries of [DB2].  All entries in the 
INI file refer to the Source Database.  Exact spelling is essential; a single 
misspelled string or name will invalidate the operation of [DB2]. 



 47

 
 

•  The first line is a fixed [Setup2] header.   
 
•  Database= 

The second line is the full path to the Source Database (or UDL file that 
represents the Source Database).  The file must have an .MDB or an 
.UDL extension.  No other files are accepted.  If the database is not an 
MS Access database (JET database), then you must use a UDL file. 
 

•  Table= 
The third line is the name of the Table of the Source Database. 
 

•  Field= 
The fourth line is the field name in the Source Database that is being 
searched for matching records. 
 

•  MustSee= 
An optional fifth line lists the ordinal numbers of the fields in the Source 
Database that must be displayed if multiple records are found, so that the 
user can determine which of the listed records to select for import. 
 

•  Use= 
An optional sixth line controls the display of the list of matched records 
and alert messages: 

 
1 =  If only one matching record is found in the Source Database,  

the value(s) is/are defaulted into the indexing fields automatically 
without a further prompt. 

2 =  No message is displayed if a matching record is not found.  
3 =  Combination of options 1 and 2. 
0 =  A list of matched records is always displayed, even if only  

one record matches.  If no match is found’ a message  
will be displayed. 

 
Example of an INI file: 
 
[Setup2] 
Database=c:\somedir\somedb.udl  (or …\somedb.mdb) 
Table=Imagetable 
Field=Image 
MusSee-5,3 
Use=3 
 
If you use both [DB] and DB2] an sample INI file might be: 
 
[Setup] 
Database=c:\somedir\somedb.udl  (or …\somedb.mdb) 
Table=ImageTable 
Imagefile=Image 
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[Setup2] 
Database=c:\somedir\somedb.udl  (or …\somedb.mdb) 
Table=Imagetable 
Field=Image 
MusSee-5,3 

 
7. Place the INI file in the same directory as the archiver software (for example 

same file as the docu100.exe program.  Check the file name of the INI file; make 
sure that it has an .ini extension (not ini.txt). 

 
8. The setup is completed.  Now, simply type the value in the respective index field 

and choose Import Data from the Edit menu (or press F4) and the specified other 
index fields will be populated with data from the Source Database.  If there are 
several matches, a list of matched records are displayed in a table, from which 
you can choose the correct record.  If the search string is alpha-numeric, you can 
simply enter the leading characters followed by the ‘%’ wildcard character, for 
example Steven% will retrieve all items starting with ‘Steven’, including 
Stevenson, Stevensen, Steven, etc. and the input field can be completed 
automatically. 

 
9. Please review a sample application below. 

 
The [DB2] option is operational only if the database is selected from the list of ‘Defined 
Databases’ (in Database Selection). 
 
 
 
Sample application for [DB2] 
 
The Assumptions are: 
 
The Main Index Database (c:\orders\orders2005.mdb) has the following fields: 
 
Order Number 
Customer ID 
Customer Name 
Customer State  
 
The Source Database (c:\customers\customers.mdb) has a table called ‘Customers’ with 
the following fields: 
 
Customer Number 
Customer Since 
Customer Name 
City 
State  
Zip Code 
 
The Customer ID in the Orders database and the Customer Number in the customer 
database are assumed to be related. 
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As we post new orders we want the Customer Name and Customer State to be imported 
into the Order Indexing window. 
 
The Setup Procedure is: 
 
We open the Orders2005 Database (for example c:\orders\orders2005.mdb).  From the 
Files menu of the Indexing window, we choose Database Setup.  We give the database 
the user-friendly name of Orders.  In the Database Setup window we make the 
following entries: 
 
We select the field ‘Customer Name’ from the pull-down list and in the Default field we 
type [DB2]3  (this refers to the third field in the Source Database), and we confirm the 
entry. 
 
We select the field ‘Customer State’ from the pull-down list and in the Default field we 
type [DB2]5  (this refers to the fourth field in the Source Database), and we confirm 
the entry. 
 
With Notepad, we create a text file with the following entries: 
 
[Setup2] 
Database= c:\customers\customers.mdb 
Table=Customers 
Field=Customer Number    (see *)   
MustSee=3,4, 5    (see **) 
Use=1     (see ***) 
 
*  Customer Number is the field that links to the Main Indexing Database. 
**  On multiple matches we want to see the customer name, city and state. 
***  If there is a unique match, then the imported data should be  

inserted in the indexing window without a further prompt.  
 

We give the created text file the name orders.ini (the name of the user-friendly 
database) and save it in the same folder as the archiver software (same folder as 
docu100.exe). 
 
Setup is complete.   
 
We restart the Order database.  We must open it from the list of ‘Defined Databases’ in 
Database Selection. 
 
Now, after we type a Customer ID in the Orders database we can choose Import Data 
from the Edit menu (or press F4) and the system will locate the customer information in 
the Customers database and extract the Customer Name and State and insert it into the 
specified fields in the indexing window. 
 
By default, the Database Setup specifications are saved in the User’s Windows Registry 
(HKEY_LOCAL_MACHINE).  To save the settings in the HKEY_CURRENT_USER, so 
that they can be shared by all users, please change the default in Setup. 
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ODBC Databases 
 
ODBC databases require some special consideration.  In many cases you can open the 
ODBC database via a UDL file (see section below).   
 
If that is not possible, use this one-time setup procedure: 
 

a) Open the PlayDB (from File | Database Selection) 
b) Open the Indexing window, and from the File menu, choose Database Setup.  

When prompted for a Short Name, give it the name you want to use for the 
ODBC database. 

c) In the Database Setup window, make no entries but press the OK Save button.  
This will create a Windows Registry entry for the database. 

d) Open the Windows Registry HKEY_LOCAL_MACHINE Software\Informatik 
Inc\Infothek and click on the database (the associated short name). 

e) Edit the Connection String, Table and Imagefile values to correspond with your 
ODBC database. 

f) Close Docudex and re-open. 
g) From File menu, choose Select Database, and select the database from the 

‘Defined Databases’ section.  
 
 
 

Universal Data Link File (.udl) 
 
The UDL file is a Microsoft concept and makes connections with databases easy.   
 
The Data Link File (Universal Data Link – UDL) provides a simple method for specifying 
database connection strings.  The database connection command simply points to the 
UDL file which contains all information needed to open the database. 
 
Data Link Files are created as follows (see also Windows reference manuals): 
 

1. In Windows Explorer select the folder where you want to create the UDL file. 
2. From File menu in the Windows Explorer, select New, then select Text 

Document. 
3. Assign the new file a file name of your choice; it must have a .udl extension 

name.  It is suggested that you save all the UDL files together in one folder, 
ideally in the same folder as the Docudex program files. 

4. Right-click on the newly created and renamed file, and select Properties from the 
pull-down list. 

5. Click on the Provider tab and select the appropriate provider (for example, for MS 
Access you would normally choose the Microsoft Jet 4.0 OLE DB Provider).  
Review your database reference manual for further instructions. 

6. Click on Next button, or choose the Connection tab. 
7. Select the database file (use the Browse button to find the database file) 
8. Click on OK to confirm. 
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If you are creating a UDL file for an ODBC database, or for advanced MS Access use, 
you should also make certain entries in Database Setup (see Database Setup section 
below). 
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