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Introduction 
 
Informatik Archiver ™ (Archiver) is a document archival program for documents of 
various formats.  Data of a document (such as date, type of document, references, user, 
etc.) is indexed to the database for later search and retrieval.  The database can be a 
Microsoft Access database or an ODBC database.  The system requires the Microsoft 
.NET Framework 2.0, 3.0 or 3.5. 
 
It is strongly recommended that you spend a few minutes watch the Tutorial Video 
presentation.  The video can be accessed via the Help menu. 
 
Make sure that you have the latest version of the program.  The latest version can be 
downloaded from www.informatik.com. 
 
Whenever files may be changed or overwritten, make sure that you have a good backup 
of affected files. 
 
Some of the enhancements over previous version are: 
 

• Support for PDF files and other file formats. 

• Reading barcodes 

• Optical Character Recognition (OCR) 

• Enhanced Notes  

• More indexing features 

• Etc. 
  
 

Requirements 
 
The system requires the Microsoft .NET Framework 2.0, 3.0 or 3.5.  If you have a fairly 
recent computer model, you probably already have the Framework files.  If not, 
Framework can be freely downloaded from Microsoft (www.microsoft.com).  Please 
contact support if you have any problems finding the Framework. 
 
You should use a screen size and resolution of 1024x768 pixel or better. 
 
The program features an embedded PDF Viewer.  The embedded PDF viewer is a 
subset of the full Adobe Reader, but it has the advantage of opening all the PDF files in 
a single-instance window, i.e. a new window is not opened for each file.   The embedded 
PDF Viewer requires that you have the free Adobe Reader  (free program) installed on 
your PC. 
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Trial Version 
 
You may use the free trial for thirty (30) days.  After 30 days you must uninstall the trial 
software or purchase a software license.  Please note that once the database reaches 
about 200 records, a nag window is displayed covering a small part of the window.  If 
within the 30 days trial period, you may still work around that nag display.   
 
When you purchase a software license you will be given a license code.  The license 
code must be entered in the Help menu (Registration).  Exact spelling is important, if 
possible enter the code with copy/paste.  The license codes and password must be kept 
confidential. 
 
 
 

Getting Started 
 
Start up the Archiver program.  There are THREE common methods to launch the 
program: 
 

o Click on the Archiver icon on the desktop.  
o Or, click on Start button (lower-left corner of window) -> All Programs -> Archiver. 
o Or, double-click on the Archiver.exe in the Program Files\Informatik Inc\Archiver 

folder. 
 
The Archiver program opens in either the ‘Archive’ or ‘Search’ mode.  The program 
opens in the last used mode, or you can specify your preference in Setup (General 
Setup).   Setup can be found in the File menu.  
 
Click on either the ‘Archive’ or the ‘Search’ tab: 
 
‘Archive’ allows you to add and index new documents to the Archive database. 
‘Search’ allows you to search the database for previously indexed documents. 
 
The program opens with the previously accessed database.  The first time that you use 
Archiver, it opens with the Sample database, because you have not yet set up a real 
database.  The Sample database is merely for demonstration; it is over-simplified.  The 
real database that you are about to create can have up to 30 fields and has a large 
number of options, features and functions.    
 
Please read next section about selecting and opening a database. 
 
 
 

Database Selection 
 
The initial version of the Archiver includes a tutorial database that you can use to 
experiment with the software.  The tutorial database is a simple Microsoft Access 
database.  The Archiver supports most databases, including ODBC databases. 
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To select another database, click on the Database menu and choose Select Database.  
Click on the database name that you wish to open and press the ‘Open Database’ 
button.  If the database is not listed in the list box, click on ‘Other’, browse to the folder 
that holds the database file and press the ‘Open’ button.   
 
It is suggested that you give the databases user-friendly, meaningful names.  In the 
Database Selection window click on the ‘Alias’ button and type the user-friendly name.  
Once you have given an alias, always open the database via that name; do not use the 
‘Other’ for that database as this would create a new listing and the new listing would not 
link to the special database setup specifications that you may have created. 
 
The first time you use the database you may be asked to select the table (if more than 
one table exists in the database), and the FilePath field that holds the path to the 
document (if that field name is not called FilePath). 
 
For databases other than Microsoft Access, you should create a UDL file.  The simple 
procedure is explained in a separate section below.  Once the UDL file has been 
created, open it for the first time by clicking on the UDL file; to re-open it again, pick the 
database item from the database list box, as explained above. 
 
Listed database items can be removed from the listing.  In the Database Selection 
window select the item that you wish to remove and click on the ‘Remove’ button.  After 
confirmation, the item will be removed.  Removed items can be re-inserted and the 
database setup specifications reactivated.  In the Windows Explorer, open the DB 
subfolder of the program file (probably C:\Program Files\Informatik Inc\Informatik 
Archiver\DB\Backup folder).  You will see the ‘removed’ files listed.  To reinstate the 
files, copy them back from the \DB\Backup folder to the  \DB folder.    
 
The next time start the Archive program, the last used database will be pre-selected and 
will open automatically. 
 
When the database opens, the Archive and the Search windows are populated with all 
the fields of the database.  Initially, the fields are listed in the order in which the database 
was created.  As you will see in Database Setup, the display order of the fields can be 
changed easily.  You can also specify default entries, repeat entries, barcode and OCR 
options. 
 
To change the database again, simply choose Select Database from the Database 
menu. 
 
If the database file is moved or renamed, you will get an error message the first time you 
log on.  Just restart the program, re-select the database and the links will be re-
established.  If the problem persists, review the files in the C:\Program Files\Informatik 
Inc\Informatik Archiver\DB folder.  Each database must have a .db.xml file and possibly 
one or more .fxml files for setup information.  If there is a problem with opening a 
database, remove the .db.xml file and re-select the database.  Generally, do not remove 
the fxml files as these contain the default settings. 
 
In special situations where you may need to change the database connection string (for 
example passwords or user names), go to Setup (Database Global) and change the 
connection string.  Caution is advised. 
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To create a database (Microsoft Access), please read the Create Database section 
below. 
 
 
 

Scanning Documents  
 
If your document archive uses TIFF files, the documents need to be scanned first.  The 
Archiver program includes a basic scanning option in the Image Viewer window.  For a 
comprehensive scanning software please download the powerful Informatik Scan from 
www.informatik.com.  Informatik Scan can save the scanned images to either TIFF or 
PDF.  The site and Pro license of the Archiver software includes a license for the 
Informatik Scan. 
 
For your testing of the Archiver, several sample TIFF files are included in the Program 
Files\Software\Informatik Inc\Archiver folder. 
 
Typically, you scan an entire batch of documents with the scanning software.  Then, 
after the scanning  of the batch, you open the Archiver program and index the individual 
documents that were scanned.  There are many options to facilitate easy indexing and 
these are explained in the various sections of this user guide.  For example, if you scan 
the documents into a sub-folder called ‘Pending’, the files are automatically moved from 
the Pending folder to the parent folder of the Pending folder.  There are many options to 
default index entries. 
 
If you prefer to scan and index one document at one time, a partial integration of the 
Informatik Scan program with the Archiver is possible.  In the Informatik Scan Setup set 
the “Integration with Archiver’ checkbox.  Then, after you have scanned a document, 
click on the Index button that appears in the image display.  The Archiver window will 
open (blank).  If necessary, change to the Indexing window.  From the File go to ‘Open 
Scanned Image’.  Index the document.  When done, return to the Informatik Scan 
program with the standard Windows shortcut ALT+Tab. 
 
 
 

Open Image Documents  
 
The Archiver can support virtually any file format, although it is mainly written for TIFF 
files, and also for PDF files.  If you open any other formats of files, they are opened with 
that document’s native application, based on the association of the file extension. 
 
For better understanding of the different formats that are supported, here are the 
essentials: 
 
By default, all files with a .tif, .bmp, .gif, .png or .jpg extension are opened with the 
embedded image viewer.  You have two other options.  In Setup (General Setup) you 
can specify that the system opens these files with the Windows default application 
(based on the associated file extension), or you can set a specific viewer application.  



 7 

Although TIFF files generally have a .tif extension, you can specify an alternate 
extension name in Setup (TIFF Viewer tab).  Files with the alternate extension name can 
then be opened with the embedded image viewer (and in some cases other viewers). 
 
By default, all files with a .pdf extension are opened with the embedded PDF viewer.  
The embedded PDF viewer is very basic.  You have two other options.  In Setup 
(General Setup) you can specify that the system opens these files with the Windows 
default application (based on the associated file extension), or you can set a specific 
PDF viewer application.  The embedded PDF Viewer requires the correct version of the 
Adobe Reader.  See also Requirements section above. 
 
Files with other extensions names are opened with the application that is associated with 
the given extension name of the file.  Extension association is set in Windows setup. 
 
The Open File dialog of the Search window and the Archive window shows a fixed list of 
extensions in the ‘Files of type’ pull-down list.  You can add extensions to that list in 
Setup (General Setup).  The syntax of the entry must be (for example): xxx,yyy,zzz.  
Note, these additional extensions are shown only in the Open File window of the Archive 
and Search windows, not in the viewers. 
 
The embedded Image viewer is a fully featured viewer.  It supports multi-page TIFF files 
and many other graphics formats, but PDF files are opened with the separate PDF 
viewer.  The images can be displayed at actual size, fit-to-width or fit-to-size.  For 
multi-page TIFF files, the viewer displays thumbnails.  The thumbnails can be enabled 
or disabled from the toolbar; they can also be disabled in Setup (TIFF Viewer).  Finally, 
the viewer operates a pan window that is useful when viewing large images. 
 
 

Archive (Indexing) 
 
Until we build a database, we will use the Sample database.   
 
The Archive option allows you to add and index new documents to the Archive database 
(indexing).   Indexing is straightforward.  There are also many labor-saving functions and 
shortcuts that in some cases can make the indexing virtually automatic.  For these 
options, please see the Database Setup section below. 
 
Forgetting for a moment the extensive shortcuts, the basic method of indexing follows 
these few steps: 
 

• Click on the Archive tag in the main window.  The indexing window opens with all 
database fields listed.  If the primary key field is an auto-incrementing value, the 
field will be disabled since you never need to make or change the entry.  The 
auto-incrementing value will be assigned by the system when you save the 
record.  By default, the field that holds the path to the indexed document (in most 
cases called File Path) will also be disabled, because it also will be filled by the 
system.  However, the field can be enabled in Setup (Database Global).   

 
The fields are listed in the order set in the database.  You can change the display 
order in Setup (Database Global). 
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• Open the document that you wish to index.  The document should be opened 
from the Archive window.  Click on the ‘Open File’ icon in the toolbar, or choose 
the ‘Open File (New) option from the File menu, or press Function Key 9.  The 
most common file extensions (.tif, .pdf, .etc.) are listed in the ‘Files of type’ pull-
down, but you can add other extensions via Setup (General Setup) from the File 
menu.  Select the file.  The file will open with the embedded viewer or with the 
application that is associated with the extension name in Windows setup.  For 
TIFF (and other graphics files) and PDF files you can specify other default viewer 
programs in Setup (General Setup) from the File menu. 

 
The first time you use the viewer, resize it to fit the left side of the screen, 
snuggly fitting next to the Archiver display. 

 
If the document has previously been indexed, the Archive window will already be 
populated with the data.  For documents that have not been indexed, which 
would normally be the case, only the File Path field will be populated.  The File 
Path field is disabled by default, but it can be enabled for a database in the 
Database Setup.  Many of the other fields can also be pre-populated (such as 
date, user name, document type, document type, filename elements, etc.).  For 
the extensive default options, such as defaults, dates, barcode and OCR options, 
etc. please read the Database Setup section in this user guide. 

 

• Enter the index data into each field and press the Tab key to move to the next 
field.   

 

• Press Function Key 3 to copy the data from the same field in the previously 
saved record.  The system immediately validates the entry and tells you if there 
is an error.  Make sure that numeric fields have a valid number, and that date 
fields have a valid date entry.   

 

• To enter a date, you can use the calendar icon, or use the Calendar option from 
the File menu.  Click on the date, and the system will insert the selected date in 
the field that has the focus.  To select the today’s date, or the date of the current 
document, right-click on the calendar and select the option.  To cancel the 
calendar without making an entry, click on the calendar button again, or click 
anywhere on the window background.  

 

• If a field is set to Auto-Increment, the field will appear in the Indexing window 
but will be disabled.  The system will post a unique and auto-incrementing value. 

 

• For copy/paste Windows Clipboard functions use the standard Windows 
shortcuts:  Ctrl+C for copying and Ctrl+V for pasting. 

 

• You can clear all entries with the Clear icon in the toolbar (‘clr’ icon), or the clear 
function in the File menu, or Function Key 7.  All fields, except the FilePath are 
cleared.  But you probably want to confirm the entry.  To confirm, click on the 
Confirm icon (check mark) or the Confirm Update+Next icon (check mark and 
plus sign), or choose the option from the File menu or the corresponding 
Function Key shortcuts Ctrl+U and Ctrl+N (or alternative CTRL+Spacebare).  The 
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Confirm Update+Next confirms the entry and automatically opens the next file.  
Hint!  When indexing the next document, don’t forget to use the Function Key 3 
to repeat entries from the previous record. 

 

• Typically, you will create one index for each document.  If you need to create 
multiple entries for a document, proceed as follows:  If the file is already open, 
press the Clear (‘clr’) icon to clear all entries, except the FilePath entry, then 
make additional entries and confirm.  If the file is not open, open the file, press 
Clear and make the entries. 

 
The Pending option is very useful in many cases.  If the image files are in a folder 
whose path name includes a folder called Pending (exact spelling!), then, upon indexing, 
the file is automatically moved to the parent folder of the Pending folder, thus leaving the 
image folder with just un-indexed files.  For example, all your new image files are placed 
in a folder called C:\Documents\Pending or C:\Documents\Pending\NewFiles.  As you 
index the files, they are moved to the C:\Documents folder, leaving the Pending (or 
NewFiles) folder with only the un-indexed files. 
 
If you move the image files after they have been indexed, it is important that the new 
location of the files has exactly the same path as the original path, except for the driver 
letter.  The program can still find the file even if the new driver letter is different than the 
drive letter in the index database (although with some extra strain on performance).  For 
example, if you index to the C:\documents\2009\myfile.tif and later move the files to a 
archival CD, the new path must be, C:\documents\2009\myfile.tif (the drive letter is just 
an assumption).  It is important that the folder and sub-folder names remain unchanged. 
 
 
For Batch Indexing, please read section below. 
 
 
 

Search (Query) 
 
The Archiver has powerful, yet easy-to-use query functions. 
 
Press the Search tab in the main window.  The Search window opens. 
 
Most query criteria and specifications can be saved so that they become the default for 
the next query.  To save the criteria and specifications, choose ‘SaveSettings’ from the 
File menu.  
 
Up to four search criteria can be specified for each query.  Select the search field and 
the Search Operator from the pull-down lists and type in the Search Criteria.  If your 
search covers more than one field, by default the query command assigns the AND 
operator.  If necessary, change the operator to OR.  If your search extends to three of 
four search fields, and the query has at least one each of an AND operator and an OR 
operator, the AND operators are executed first, as per the following schema: 
 

(aaa AND bbb) OR  (ccc AND ddd) 

(aaa AND bbb and ccc) OR ddd 
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Aaa OR (bbb and ccc and ddd) 

 
The following search operators are available and should cover all your needs. 
 
STARTS WITH for strings, numbers, dates 
STARTS NOT WITH for strings, numbers, dates 
IS EXACTLY for strings, numbers, dates, Boolean 
IS NOT for strings, numbers, dates, Boolean 
INCLUDES for strings, numbers, dates 
MORE OR EQUAL THAN for numbers and dates 
LESS OR EQUAL THAN for numbers and dates 
 
Hint! The STARTS WITH can be used in virtually all cases.  If in doubt, use the STARTS 
WITH operator. 
 
When the search criteria are entered, click on the Search button, or select Run Search 
from the File menu, or press Function key 8.  The matched items are listed in the query 
results table. 
 
Note that the fields in the result table are listed in the original database field order.  The 
field order can be changed in Setup (Database Setup).  It is suggested that for practical 
reasons the FilePath and the ID fields are placed last.  The initial sort of the displayed 
records is also according to the field order set in Setup / Global Database (Query 
Results). 
 
With some experience and practice, you will quickly master virtually any query type. 
 
The search specifications can be saved as a default.  To save the specifications, choose 
the Save Settings option in the File menu.  
 
To sort the result table, simply click on any of the field headers.  The initial sort of the 
displayed records is also according to the field order set in Setup / Global Database 
(Query Results).  The sort sequence is according to the order of the table columns in the 
result table (first column is the primary sort, second column is the secondary sort, etc.).  
To change the sort sequence, up to 4 levels, change the order of the columns.  To move 
the columns, drag the column header to the desired location. 
 
If the data is truncated or hidden and you need to see the full details, click on the Details 
button, or simply right-click on the record.  To resize (widen) the column width in the 
table, drag the right border of the field header.  To save valuable screen space, the 
window is kept small; some database fields may not be shown.  As explained above, the 
field display order for either the indexing or search (or both) can be changed in the Setup 
(Database Global).  You may want to consider moving the important fields to the front.  It 
is suggested that you make the FilePath field the last field.  The FilePath column is extra 
wide and should be at the end of the grid. 
 
Due to the limited display area, some of the columns may be hidden.  Use the horizontal 
scroll bar to view the hidden columns, or resize of the window by dragging the right 
border.  You can also re-arrange the columns, i.e. move the most important column to 
the front by simply dragging the column headers to the desired position.  To quickly see 
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the data of all columns, right-click on the record row; the data is then displayed as long 
as you hold down the mouse button.  Alternatively click on the Detail button. 
 
To view the detail of all data fields, click on the Detail button.  The Detail window stays 
open until you close it.  The data is refreshed each time you click on a record.  This 
option allows you to copy the data into the Clipboard.  Alternatively, right-click on the 
record. 
 
To view the document of any of the listed records, click on the record, and click on the 
‘Open File’ button. You can also click on the Next and Prior navigation buttons (arrow 
icons).  The document will open in the application associated with the extension name of 
the file.  For TIFF and PDF files you can specify a default viewer in General Setup, in the 
Options menu. 
 
To print the document of any of the listed records, click on the record, and click on the 
‘Print File’ button.  The document will printed by the application associated with the 
extension name of the file.  If the associated application does not accept a ‘print’ 
request, open the file, then request a print from the application’s File menu.  Only one 
file can be requested at one time. 
 
To edit listed records, first select the records.  Several records can be selected.  To 
select a contiguous range of records, click on the first record in the left header cell 
(empty gray cell), and while holding down the Shift key, click on the left header cell of the 
last record in the range.  To select non-contiguous records, click on the records in the 
left header cell while holding down the Ctrl key.  To select multiple records you can also 
select them simply by right-clicking on a data cell.  After the records have been selected,  
click on the ‘Edit Records’ button, or choose the option from the File menu.  The 
Indexing window now opens.  Click on the arrow button next to the Selected Records’ 
pull-down list to move to the next record, or select the record from the pull-down list.  
Make the necessary corrections to the record and confirm the entry by clicking on the 
Confirm icon (check-mark) or choosing the Confirm option in the File menu.  Always 
confirm the change before you move to the next record.  For batch updating, see the 
Batch Updating section in this manual.  
 
To delete listed records, first select the records.  Several records can be selected.  To 
select a contiguous range of records, click on the first record in the left header cell 
(empty gray cell), and while holding down the Shift key, click on the left header cell of the 
last record in the range.  To select non-contiguous records, click on the records in the 
left header cell while holding down the Ctrl key.  Or, you can select single or multiple 
files by simply right-clicking on the data cell.  From the File menu, choose ‘Edit/Delete 
Selected Records -> Delete Selected Records (or Delete Selected Records and Indexed 
Image Files).    
 
The Save Selected Record Data as Text File option creates a readable text file with 
the data of the selected records.  The file includes both the field labels and the data, 
arranged in a vertical layout. 
 
The Print Selected Record Data option creates a temporary text file with the data of the 
selected records and displays the file in Notepad or in the program that is associated (in 
Windows setup) with the .txt extension name.  The file includes both the field labels and 
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the data, arranged in a vertical layout.  The file can then be printed with Notepad’s 
printing functions. 
 
For diagnostic purposes, the SQL query string can be viewed by choosing the View SQL 
String in the File menu. 
 
The Search window can be cleared with the Clear Screen function in the toolbar (‘cross-
out’ icon) or File menu, Function Key 7. 
 
Need to know the Size of the Database?  Choose Get Database Size in the file menu. 
 
For Global Editing, see separate section below. 
 
For Exporting, see separate section below. 
 
If the file names in the index do not include the path name, you can specify a ‘make-up’ 
path in Setup (General Setup) in the File Path field.  When running the query, the file 
path specified in Setup will be used as a path prefix. 
 
To Copy Selected Data Cells to the Clipboard, click on the individual cells that you 
wish to copy while holding down the CTRL key, then choose the ‘Copy Selected Data 
Cells’ option from the Edit menu.  You may need to un-select a fully selected row; click 
on the left-most header cell of the row while holding down the Ctrl key. 
 
 

Notes 
 
You can enter notes for each indexed document.  When you later open the document an 
alert appears telling you that associated notes exist for that document.  The option is 
available only for indexed documents and only for files viewed with the embedded 
viewers. 
 
The Notes are saved in a .txt file together with the image document.  If you move a 
image document make sure that you also move the .txt file. 
 
The Notes option must first be activated in Setup (General Setup tab). 
 
To create a note: 
 
Open the indexed document.  Select Notes from the File menu (or use the F6 shortcut 
key).  Enter the text and click on Save button. 
 
To read a note: 
 
When you open a document in an embedded viewer (Image Viewer or PDF Viewer), you 
see an alert telling you about the existence of the notes.  The alert disappears after a 
few seconds.  You also see an icon at the top of the window to indicate the existence of 
the notes.  Choose Notes from the File menu or use the F6 shortcut key to open the 
Notes. 
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Do not rely totally on the alert; there may be notes when you do not see an alert, or vice 
versa. 
 
 

Launch Linked Applications 
 
The program allows you to open other applications with the current file name being 
passed to the launched application as an argument (parameter). 
 
Applications can be launched from the embedded Image Viewer and the Search 
window. 
 
Select up to three (3) applications from Setup (General Setup).  When you restart the 
program, the applications will be listed in the embedded viewers’ File menu, and icons of 
the applications will be shown in the Search window’s tool bar.  The icons of the 
applications will bear the first letter of the application.  Simply click on the icon and the 
application will be launched with the current file name passed as an argument.   
 
You can create your own icons.  Simply place your icons in the program folder (same 

folder as the Archiver program’s executable file).  The icons MUST be named AppA.ico 

and/or AppB.ico and/or AppC.ico.  The graphics format of the icon image need not 

be an icon; it can be a BMP, PNG, etc., but the extension must be .ico. 

 
Alternatively, you can copy the file name of the currently open image file to the Windows 
Clipboard, then start an external application and paste the file name in that application.  
The Copy File Name to Clipboard function can be found in the Edit menu of both the 
embedded Image Viewer and the PDF Viewer. 
 
Custom Arguments.  By default, the file name is passed to the Application. Additional 
argument elements can be passed with the Custom Arguments options.  Use [f] as the 
placeholder for the filename and [d] as the placeholder for the filename’s directory.  For 
example, to open a folder that contains the current file, select the 

c:\windows\explorer.exe as the application and set the Custom Argument to [d].  

To merely select the folder (without opening it), set the Custom Argument to 

/select,[d].  To force the filenames to be encapsulated in single quotes, for 

example, use the string  “[f]” (including the quotes).  To add a switch, for example, 

the string would be /a “[f]” 

 
 
 
 

Create a Database 
 
You will need to create a database that is specific to your indexing needs.  Archiver 
supports databases up to 30 fields.  One of the fields must be a primary key with a 
unique value. 
 
The database can be a Microsoft Access database or almost any ODBC database.  You 
can create the database with your database software, or you can use the simple 
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database creation tool supplied with Archiver (Microsoft Access database).  If you create 
a database with your database software, keep the following in mind: 
 

o The number of fields must not exceed 30.  
o One field must be a primary key field.  It is suggested that you make primary key 

field an auto-incrementing field (select Auto-incrementing from the pull-down list). 
o One field must hold the path to the indexed document; this field ideally should be 

called ‘FilePath’.  
o Ensure that the field names are compatible (no reserved words, no spaces, no 

special characters, no leading numbers).  
o If possible, the database should have a single table. 

 
To create the database with the Archiver Database Builder tool, follow these steps: 
 
From the Database menu, choose Create New Database.  The Database Builder 
window is displayed.  
 
Type the field name in the text boxes in the first column.  Do not use reserved words, 
such as Date, Name, Text, Where, Level.  The file name must not start with a number, 
for example 2006Docs.  The file name must not have spaces or include special 
characters. 
 
Specify the data type from the pull-down list.  For Text fields, enter the maximum 
number of characters.  Generally, for all fields, you should check the 'Indexed' checkbox.  
If the database should allow a blank entry, then un-check the 'Allow Null' box. 
         
One field must be designated as the 'Primary Key Field'.  It is recommended that you 
create an auto-incrementing primary key field; select ‘Auto-increment Primary Key’ from 
the Data-Type pull-down list.  Alternatively, specify the primary key field in the right-side 
column. 
 
The database for Archiver requires a field that holds the path to the indexed document.  
That field will be created automatically by the system, if you do not create it.  It is 
recommended that you let the system create that field.  If you do create it yourself, name 
it 'Filepath'), even though Archiver can work with alternative field names. You will be 
prompted to change the field size. 
 
It is suggested, for practical purposes, that you make the auto-incrementing ID field the 
second last item and the FilePath field the last item. 
 
There is a maximum of 30 fields; one table per database.  The table name is 
automatically assigned to be 'Archive'. 
 
Click on the OK button to build the database.  On the prompt, enter a new database 
name.  Make the database a short but meaningful name, no spaces in the name.  The 
database name must have an .mdb extension name. 
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Databases with password protection must be created with database software, for 
example Microsoft Access, and the database must be opened via a UDL file.  For a 
discussion on UDL, see separate section in this manual.  If you do not use a UDL, the 
connection string must include a reference to the password and user ID, for example:  
 
Provider=Microsoft.Jet.OLEDB.4.0;Password=[Password];User 

ID=[Id];Data Source=C:\SomeDir\documents.mdb;Persist 

Security Info=True.  With this syntax of the connection string, the system will 

prompt the user to enter the password (and id). 
 

 
 
 

Update and Delete Records 
 
Deleting or updating existing records are done via the Search option.  Run a search that 
will identify the record(s) that you wish to update or delete.   
 
To edit listed records, first select the records.  Several records can be selected.  To 
select a contiguous range of records, click on the first record in the left header cell 
(empty gray cell), and while holding down the Shift key, click on the left header cell of the 
last record in the range.  To select non-contiguous records, click on the records in the 
left header cell while holding down the Ctrl key, or simply right-click on a cell of the 
records that you wish to select.   Click on the ‘Edit Records’ button, or choose the option 
from the File menu.  The first of the record is then displayed in the Indexing window.  
Click on the arrow button next to the Records pull-down list to move to the next record, 
or select the record from the pull-down list.  Make the necessary corrections to the 
record and confirm the entry by clicking on the Confirm icon (check-mark) or choosing 
the Confirm option in the File menu.  Always confirm the change before you move to the 
next record.   
 
For batch updating, see the Batch Updating section in this manual.  
 
To delete listed records, first select the records.  Several records can be selected.  To 
select a contiguous range of records, click on the first record in the left header cell 
(empty gray cell), and while holding down the Shift key, click on the left header cell of the 
last record in the range.  To select non-contiguous records, click on the records in the 
left header cell while holding down the Ctrl key, or simply right-click on a cell of the 
records that you wish to select.  From the File menu, choose ‘Edit/Delete Selected 
Records -> Delete Selected Records (or Delete Selected Records and Indexed Image 
Files).   After confirmation, records are permanently deleted; the image file and 
associated Notes file are deleted, but copied to the Recycle Bin.  Use this option with 
caution.  Always make sure that you have a good backup of the database and the 
images. 
 
For Global Update and Delete options, see the Global Updating and Deleting section in 
this manual.  
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Global Updating and Deleting of Records  
(Advanced Use) 
 
The recommended approach to updating and deleting records is via the Indexing 
window, as explained in the Update and Delete Records section in this manual.  
However, there is also a global method.  If you use the global method, it is essential that 
you make a good backup of the database before you proceed.  It is strongly 
recommended that you first practice with a dummy database. 
 
Run a search that will identify the record(s) that you wish to update or delete.   
 
Select the records that you wish to update.  To select a contiguous range, click on the 
left row label (left header cell) of the first record in the range, and while holding down the 
SHIFT key, do the same for the last record in the range.  To select non contiguous 
records, select the records by clicking on the left row label while holding down the CTRL 
key, or simply right-click on a cell of the records that you wish to select.   
 
 
There are two methods of globally updating database record fields: 
 
A.  Update the Filepath field 
B.  Update any of the fields 
 
The options are accessible from the Global Editing in the File of the Search window. The 
options are enabled only after your run a query and have selected some records. 
 
 
Update the Filepath Field 
 
The following five options are available, and accessible from the File menu: 
 
1. Add Prefix.   
2. Replace the drive letter. 
3. Replace the drive letter and the top directory. 
4. Replace the drive letter and the top two directories. 
5.  Replace the drive letter and the top three directories. 
6. Replace entire path. 
 
Option 1 adds a prefix to the file name; options 2-5 replace the drive letter and 
directories. 
 
To replace the ‘\\’ mapping prefix, use Option 2. 
 
Run a query to list the records that need updating, then select the option from the File 
menu -> Global Editing -> Edit Filepath Field -> (Select Option).  Follow the prompts. 
 
Update Other Fields 
 
These options allows you to update the selected records of one specified field.  The 
replacement value can be a fixed text, and you can include placeholders.  Placeholders 
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represent all or part of the value of the original record data.  The following placeholders 
are supported: 
 
[*] represents the entire original data 
[5] represents the first 5 characters of the original data.  You can use any number. 
[-5] represents the last 5 characters of the original data.  You can use any number.  
[2:3] captures 3 characters starting from the second character to the left 
[-5:3] captures 3 characters starting 5 characters from the end. 
 
The specification can be a mix of fixed text and one or more placeholders. The numbers 
in the samples above are just for illustration; you can use any numbers that are valid 
within the context of the data string. 
 
Examples global update specifications: 
 
DEC[*] 
[*]ABC 
ABC[2]XX[[-1] 
ABC[2:2] 
 
 
 

Image Viewer 
 
Please also read the Open Image Documents section.  The embedded Image viewer is 
a fully featured viewer.  It supports multi-page TIFF files and many other graphics 
formats.  The images can be displayed at actual size, fit-to-width or fit-to-size.  For multi-
page TIFF files, the viewer displays thumbnails.  The thumbnails can be enabled or 
disabled from the toolbar; they can also be disabled in Setup (TIFF Viewer).  Finally, the 
viewer operates a pan window that is useful when viewing large images. 
 
 

PDF Viewer 
 
Please read the Open Image Documents section.  The embedded PDF viewer requires 
the correct version of the free Adobe Reader; please read the Requirements section. 
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Setup 
 
The Setup is accessible from the File menu of the main window.  If you don’t see the 
menu item, click on the Search or Archive window and try the menu again.  Setup has 
four distinct sections, each accessible by clicking on the corresponding tab: 
 
a) Global Database  
b) Database Fields  
c) General Setup   
d) Tiff Viewer (Image Viewer) 
 
 
The setup data for Global Database and Database Fields is stored in .xml and .fxml files 
in the C:\Program files\Informatik Inc\Informatik Archiver\DB folder.  If a database is 
deleted and no longer used; the corresponding .fxml file should be deleted.  If you install 
the program on another PC and you wish to keep the database settings, simply copy the 
files. 
 
The setup data for General Setup and TIFF Viewer is stored in Setup1.resx and 
Setup2.resx files in the C:\Program files\Informatik Inc\Informatik Archiver folder.  If you 
install the program on another PC and you wish to keep the general default settings, 
simply copy the files (effective with version 2.50 and later). 
 
 

Global Database 

 
The Database Setup allows you to specify default settings for the currently open 
database. 
 
Setup has three options: 
 

o Re-order the sequence of the fields for indexing 
o Re-order the field sequence for searching.  Simply move the fields with the 

arrows.   When done, click on the Save button and close the window.   
o Enable File Path field in the indexing window.  By default the Filepath field is 

disabled because the entry is generated automatically.  The field can be enabled 
with this option. 

 
The Advanced section shows various settings for information only, although the 
connection string can be changed; use caution. 
 
Comments about the Connection String: 
 
Databases with password protection must be created with database software, for 
example Microsoft Access, and the database must be opened via a UDL file.  For a 
discussion on UDL, see separate section in this manual.  If you do not use a UDL, the 
connection string must include a reference to the password and user ID, for example: 
Provider=Microsoft.Jet.OLEDB.4.0;Password=[Password];User 
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ID=[Id];Data Source=C:\SomeDir\documents.mdb;Persist 

Security Info=True.  With this syntax of the connection string, the system will 

prompt the user to enter the password (and id). 
 
 
 Click on Save button to save the changes. 
The program needs to be re-started before the new settings take effect. 
 

Database Fields 

 
The Setup (Database Fields) allows you to specify a host of default options for posting 
records (indexing of documents).  The list of default options is so extensive that in some 
cases the entire indexing can be automated. 
 
From the Database menu, choose Database Setup.  The Database Setup window 
opens.  Click on the Database Fields tab. In the upper left section of the window, choose 
the field for which you want to create default entries.  The default options are as listed 
below.  After you have made the entries, click on the Save button, then choose the next 
field.  When done, close the Database window.  The program needs to be restarted 
before the new settings become effective.   
 
Defaults 
 

[DATE] 
Inserts the current system date in the short format specified in Windows setup, 
for example 01/01/06. 
 
[FILE] 
Inserts the file name of the document. 
 
[BASENAME] 
Inserts the document’s base name, the file name without the path and without the 
extension. 
 
[FILE_1], [FILE_2], [FILE_3], [FILE_4]       (or [FILE-1], etc.) 
Inserts the first section of the document’s file name, if the document file name 
has sections separated by underscores.  For example, a file name of 
c:\mydir\aaa_bbb_ccc.pdf has three sections.  [FILE_1] will extract ‘aaa’; 
[FILE_3] will extract ‘ccc’. 
 
[FILEWRITEDATE] 
Inserts the date when the document being indexed was created or last changed. 
 
[FOLDER] 
Inserts the name of the folder where the document is held, without the full path.  
This option is useful for batch processing where types of documents are placed 
in different folders.   

 
[PAGES] 



 20 

Inserts the number of pages of the document.  This applies only to TIFF files.  
The extension name of the file must be ‘.tif’. 
 
[USER] 
Inserts the current user name. 
 
[COPY] 
Copies the field entry of the preceded indexed record. This option is effective 
only for online indexing; it cannot be used for batch processing.  
 
[TICKS] 
Inserts the system tick (date and time in one-quarter-millionth of a second).  This 
option can be used to create a virtual-unique value.  The field must be of  LONG 
data type, or else must accommodate 18 characters. 
 
[XML] xxxxx 
Reads an XML file whose file name is identical to the image file name (same 
folder), except for the .xml extension name.  The xxx string represents the data 
element of the XML table, for example Customer in the sample below. 
 
Example: 
 
<Record>   
    <Customer>John Smith>  
    <Account>1234567>  
 </Record> 
 
 
[BATCH_CONSTANT1], [BATCH_CONSTANT1] 
 
These options are used for batch processing only.  See section on Batch 
Processing. 

 
DATABASE LOOKUP 
See Database Look-up below 
 
 
OCR 
 
The highlighted text string in the open TIFF file is OCR’d and copied to the 
current indexing cell.  This option is available only if the TIFF (or other graphics 
file, not PDF) is displayed in the embedded Image Viewer.   
 
(Without this database setting, you can also import OCR’d text strings without 
this option by simply highlighting the text string in the open image file, then 
selecting the option from the popup menu.) 
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BARCODE 
 
The highlighted barcode in the open TIFF file is read and copied to the current 
indexing cell.  This option is available only if the TIFF (or other graphics file, not 
PDF) is displayed in the embedded Image Viewer.   
 
You can also import barcoded data without this option by simply highlighting the 
barcode in the open image file, then selecting the option from the popup menu. 
 
The system can read a dozen different barcode symbologies.  You must specify 
the barcodes that you wish the system to consider.  Place the most likely 
symbology at the beginning of the listed barcodes.  The barcodes can be 
specified in Setup – TIFF Viewer tab.  See the Barcode section below for a list of 
barcodes. 
 

 
Mask 
 

The Mask option changes the entry to a fixed format.  In the specification, each 
variable letter or number is represented by a single question mark.  For example, 
to format a text to a phone-number format, for example, specify (???) ???-????.  
An entered string of 8001234567 will convert to (800) 123-4567 when you leave 
the indexing field.  The only wildcard character allowed is the question mark.  
 

 
Dropdown List 
 

The pull-down list can be specified in two ways: 
 
a) for short lists, simply type in the items, separated by a pipe character, for 
example: 
 
Washington | Baltimore | New York | Boston 
 
For a long list, create a text file, one line per item, and in the Database Setup 
refer to the text file, for example 
 
C:\somedir\dropdownlist.txt 
 
The drop-down list can be overwritable, where the user can type it other text, or 
non-overwritable, where only items from the pull-down list can be selected. 
 
The drop-down list can be either sorted alphabetically, or left in the unsorted 
state (in the order the items have been entered).   
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Match 
 

The Match option verifies that the entry matches one of the specified formats. The 
Match option uses the LIKE operator and thus supports various wildcard characters, 
such as 
 

• * for one, none or several characters of numbers 

• ? for a single character or number 

• # for a single number 
 
Database Lookup 
 

If Database Lookup is specified for a field, a button in the indexing window is 
displayed next to the field.  Which pressed, an SQL query is executed and the 
look-up database opens with the results displayed in a data grid.  The user can 
select the entry from the displayed database grid.  The Database Lookup 
requires two specifications:  a) the connection string and b) the SQL query string.   
 
The syntax of the connection string depends on the type of database you use for 
the lookup.  The connection string for a MS Access database typically would be 
(example): 
 
Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\xyz\xyz.mdb 
 
The syntax for the SQL query is a bit more complex, but simple if you have some 
familiarity with SQL language.  A sample of an SQL query string would be: 
 
SELECT aaa, bbb, ccc FROM ttt WHERE ddd LIKE ‘<n>’ 
 
Where aaa, bbb ccc are the fields of the lookup database that you want to list.  
To list all fields, use the ‘*’ wildcard character.  If the field names have spaces or 
are reserved words, encapsulate them in square brackets.  To be safe, always 
use square brackets. 
ttt is the name of the table of the lookup database. 
ddd is the field in the lookup database that you wish to query. 
n is the field number of the index database (not the lookup database) that holds 
the value that is used in the query.  Use the field numbers that are shown in the 
Database Setup (not necessarily the field order).  If you enter a ‘<?>’, the system 
will prompt you for an entry.  You can also enter a static text.  Don’t forget the 
encapsulating quotes. 
 
Examples of the SQL query string: 
SELECT [Account], [Customer] FROM [MyTable] WHERE [Account] LIKE ‘<3>’ 
SELECT * FROM [MyTable] WHERE [City] LIKE ‘Boston’ 
SELECT* FROM [MyTable] WHERE [City] LIKE ‘<?>’ 
 
If you like multiple fields populated, add the following text to the SQL query 
string, separated by a semi-colon (example): 
 
SELECT * FROM [MyTable] WHERE [City] LIKE ‘Boston’ ;2,4,3,5,4,6 
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In this sample code field #2 in the Database Lookup window will be posted to 
Field #4 in the Indexing window; Field #3 will be posted to Field #5, Field #4, to 
Field #6. 
 
(This multiple field population is effective with compiles after April 28,2009.) 

 
 
Read from XML File 
 
 See Defaults above 
 

General Setup 

 
The Setup (General Setup) allows you to specify settings that have global reach.  
 

o Image Viewer.  Graphics files (other than PDF files) by default are opened in the 
embedded Image Viewer.  You have two other options:  check the ‘Use Windows 
Default’ checkbox and the files will be opened with the application that is 
associated with the file’s extension name.  Extension association is a Windows 
feature.  You can also specify any other image viewer.  Check the Encapsulation 
if the passed filename should always be encapsulated in quotes.  Generally this 
is necessary if file names have spaces. 

 
o PDF Viewer.  PDF files by default are opened in the embedded PDF Viewer 

(basic PDF viewer).  You have two other options:  check the ‘Use Windows 
Default’ checkbox and the files will be opened with the application that is 
associated with the .pdf extension name.  Extension association is a Windows 
feature.  You can also specify any other PDF viewer.  Check the Encapsulation if 
the passed filename should always be encapsulated in quotes.  Generally this is 
necessary if file names have spaces. 

 
o Applications to be Launched.  See Launch Linked Applications section in this 

manual. 
 

o File Path.  If the index records do not include a complete path to the image, the 
prefix path can be entered here.  For example, if the index record shows only the 
file name ‘abc.tif’ without the full path, you can enter the missing path in the 
Setup’s File path field.  It is not recommended that you enter only file names in 
the record. 

 
o Top Drive.  If the actual files are on a different drive than what is indicated in the 

record data, the system will still find it.  The system will look in each drive (using 
the given directory) until it finds the file, starting at the driver where it found the 
previous file.  Alternatively, you can enter the driver letter in the ‘Top Drive’.  If 
you specify the drive letter, the system will only look on that specified drive. 

 
o Additional Filters.  When you open a document, the listed extensions (document 

types) are .PDF and.TIF.  You may be working with other file types as well. 
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Simply enter the associated extensions of the file types, separated by a comma.  

For example, if you wish to add Text, Excel and JPEG types, enter: txt,xls,jpg   
 

o Notes Enabled.  You can enter text associated with an image file.  When you 
open an image that has an associated text, you are alerted and you can view the 
text.  See Notes section in this manual.  To enable the Notes option, check this 
checkbox,  

 
o Custom Arguments.  By default, the file name is passed to the Application.  

Additional argument elements can be passed with the Custom Arguments 
options.  Use [f] as the placeholder for the filename and [d] as the placeholder for 

the filename’s directory.  For example the custom argument  /select, [d] 

would pass a string like ‘/select, c:\somedir’ to the application.  If the filename 
must be encapsulated in quotes, make sure that you add the quotes, for example 
/a “[f]” 

 
o Priority.  If all your image files are TIFF files, you will want the embedded Image 

Viewer to be displayed on start-up.  Or, if most of your files are PDF, you will 
want the embedded PDF viewer to be displayed.  Check either the TIFF or PDF 
option.  You can also specify whether you prefer the Archive or the Search 
window to be open upon startup.   

.                    

Tiff Viewer 

 
The Database Setup allows you to specify default settings for the embedded Image 
Viewer: 
 

o Alternate Tiff extension.  You can specify one custom extension that will be 
treated by the viewer as a Tiff extension.  For example.xyz. 

 
o Barcode Types.  The system supports 13 symbologies of barcodes.  For good 

performance you must indicate which barcodes should be considered and in 
what order. A sample of an entry is: 1,3,5.  For the barcode numbers, please 
read the Barcode section in this manual.  At least one code must be specified in 
order to activate the barcode option. 

 
o Thumbnails Enabled.  Check this box, if you want the embedded Image Viewer 

to display thumbnails (for multi-page TIFF files). 
 
 

Batch Indexing 
 
The Batch Indexing option allows you to index entire folders, and nested subfolders in on 
process.   
 
For Batch Processing to be practical all fields must have a default setting.  Default 
settings for each field can be specified in the Database Setup.  See also Database 
Setup.   
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In addition to the regular defaults, you can also set two constant values 
([BATCH_CONSTANT1] and [BATCH_CONSTANT2].  If you specify a Batch_Constant 
for a field, you must specify the constant value (text or number) in the Batch Processing 
window.  The batch process will then apply the constant value to the specified field.  The 
concept of Batch Constants will become clearer when you have a look at the Batch 
Indexing window.  
 
After the batch process has created the index, the documents are moved to the specified 
destination folder and are (optionally) deleted from the source folder.  If the process 
includes nested subfolders, all files are moved to the specified destination folder, not to 
its subfolders. 
 
If fields are left blank, the system inserts a  
 
zero (0) for numeric fields, 
1/1/1800 for date fields, 
a single blank character for text fields, 
FALSE for Boolean (checkboxes) fields. 
 
Select the Source folder, the folder where the un-indexed documents are located.  Click 
on the button next to the ‘Source Folder’ field.  Check the ‘Include Nested Subfolders’ 
and ‘Move and Delete Files’ as appropriate.   
 
Enter the Constant values, if ([BATCH_CONSTANT1] or ([BATCH_CONSTANT2] are 
set for any of the fields in Database Setup. 
 
Click on ‘OK Proceed’ button. 
 
Click on the ‘Save Settings’ if you wish to keep the settings for the next session. 
 
Always make sure that you have a good backup of document files and the database file 
before you run a batch process.  Practice with a dummy database before you run a 
batch on the live database. 
  
 

Import Database 
 
Tab-delimited text files can be imported to the database.  The import function allows you 
to re-order or omit fields in the tab-delimited file.  Make sure that all fields have a 
correctly formatted value.  If the receiving database has an auto-incrementing field, any 
values in the tab-delimited file relating to that field will be ignored and the system will 
assign auto-incrementing numbers. 
 
The import function can also be used to re-build a database.  Simply export the old 
database to a tab-delimited file, then import the file to the new database. 
 
Before you import a file to an existing database, make sure that you have a good backup 
file of the database. 
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The import function can be found in the Files menu of the ‘Archive It’ window. 
 
Before you open the Import function, select the database to which you are importing 
data.  Choose the Import function from the File menu in the Archive It window. The 
system first prompts you for the tab-delimited text file.  Select the tab-delimited text file.  
The Database Import window opens, listing in the left column all the fields of the 
receiving database.  Next to each field you will see a pull-down list with the values of the 
first record in the tab-delimited file.  From the listed values you should identify the fields 
of the tab-delimited file.  Match each field of the receiving database with the 
corresponding field from the pull-down list.  If you do not associate a field, the field will 
be left blank. For auto-incrementing fields, you can leave the field un-associated. 
 
Please pay particular attention to the following: 
 
a) make sure that the data type are compatible. 
b) ensure that there is no conflict with primary key fields. 
c) if you import to an existing database, make a full backup before you run the import 
function. 
 
Errors are posted to the error log (C:\Document and Settings\[USER]\Application 
Data\Archiver\error_log.txt) 
 
   
 

Export Database 
 
Selected records or the entire database can be exported as a tab-delimited or as an 
XML file. 
 
The export option can be found in the File menu of the Query window.  Run a query to 
enable the menu items. 
 
To export the entire database, click on the File menu and choose Export Database -> 
Export Complete Database.  In the ‘Save’ Dialog, enter the output file name either with a 
.txt or .xml extension. 
 
To export the records listed in the query results table, run a query to locate the records.   
Click on the File menu and choose Export Database -> Export Listed Records.  In the 
‘Save’ Dialog, enter the output file name either with a .txt or .xml extension. 
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Log Files 
 
The program can maintain two logs: 
 
File Access Log: 
  
This option is operational only in the licensed version and must be activated by the 
System Administrator.  Instructions are available from Technical (ask for 
‘EndUserAccess’ document).  Each time a document is opened, the user name and 
date/time is logged.  The name and location of the log file is specified with the  
EnableUserAccess setup. 
 
 
Error Log: 
 
Batch processing errors are logged for later review and corrections. 
The log file is in the C:\Documents and Settings\[USER]\Application Data\Archiver 
 
Both log files should be backed-up and/or cleared from time to time.  It is up to the 
system administrator to ensure that the access log file is not tempered with.  For special 
software compiles that use secure log files, please contact the software developer.  
 
 
 

Barcodes 
 
The system recognizes most barcodes.  When indexing documents, simply highlight the 
barcode (draw a rectangle with the mouse, while the left mouse button is pressed).  
When you release the mouse button, the bar code is read and a popup menu is 
displayed giving you the option to post the barcode value to the current index field.   
 
Alternatively, if you need to read many barcodes, create a BARCODE keyword as a 
Default in the database setup; see Database Setup section above.  With this entry you 
will not need to select an option from the popup menu; the barcode data will be posted 
directly.    
 
The following barcode symbologies are supported.  Please specify the barcode type that 
you wish the system to consider in Barcode Types in Setup (TIFF Viewer tab).  The 
types must be listed by number, in a format like: 1,2,5,8.  At least one code must be 
specified in order to activate the barcode option. 
 
 
1.   Code39 
2.   Code128 
3.   Code11 
4.   Code93 
5.   CodeI25 
6.   CodeS25 
7.   Codabar 
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8.   CodeEAN 
9.   CodeEANPlus 
10. CodeUPCE 
11. CodeTelepen 
12. CodePostnet 
13. CodeRm4scc (Royal Mail) 
 

OCR 
 

(Valid only for Informatik Archiver version 2.70 or higher) 
 

There are two OCR options: 
 

a) Simple OCR.  The option is graphics files, excluding PDF.  With your left 
mouse button depressed, outline the area of the image that you wish to 
OCR.  When you release the mouse button, select the option from the 
popup menu.  For large files, the OCR process may take several seconds.   

 
b) Extended OCR.  This option is available in the image viewers’ File menu 

(all graphics files, including PDF).  The option opens a standalone OCR 
program that features many options.  The OCR program has its own user 
guide.  For this option to work you must download the Informatik OCR 
program.  The program is free to Archiver licensees. 

 
To enable Extended OCR capabilities, please do the following: 
 

1. Download from www.informatik.com and install the trial version of the 
Informatik OCR program.  The Informatik OCR program is free for 
licensees of Informatik Archiver.   

 
2. Start the Informatik OCR program at least once.  This will establish the link 

to the program.   
 

3. If you have a license for the Informatik Archiver, enter the license code in 
the Help -> Register menu of Informatik OCR. 

 
4. The Informatik OCR is a self-contained program.  Read its user guide to 

familiarize with the many options and features of the Informatik OCR 
program. 

 
The program uses the Tesseract OCR engine.  No support can be given.  The 
initial installation includes the necessary Tessdata language files for English only.  
The default language is English but you can change the default in Setup. 
 
The OCR engine also supports French, German, Spanish, Italian, Portuguese 
and Dutch.  However, for these languages you need additional Tessdata 
language files, freely downloadable.  If needed, please go to 
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www.informatik.com/ocr.html web page and download the necessary language 
files.  Unzip the downloaded file and add the files to the Tessdata subdirectory.  
The files for all the required languages must be in that same folder.    
 
 
 

UDL - Universal Data Link File (.udl) 
 

The UDL file is a Microsoft concept that simplifies the database connections.  
You can use UDL’s with all databases, but it s highly recommended for all 
databases other than Microsoft Access.   
 
The Data Link File (Universal Data Link – UDL) provides a simple method for 
specifying database connection strings.  The database connection command 
simply points to the UDL file which contains all information needed to open the 
database. 
 
Data Link Files are created as follows (see also Windows reference manuals): 
 

1. In Windows Explorer select the folder where you want to create the UDL 
file. 

2. From File menu in the Windows Explorer, select New, then select Text 
Document. 

3. Assign the new file a file name of your choice; it must have a .udl 
extension name.  It is suggested that you save all the UDL files together in 
one folder, ideally in the same folder as the Docudex program files. 

4. Right-click on the newly created and renamed file, and select Properties 
from the pull-down list. 

5. Click on the Provider tab and select the appropriate provider (for example, 
for MS Access you would normally choose the Microsoft Jet 4.0 OLE DB 
Provider).  Review your database reference manual for further 
instructions. 

6. Click on Next button, or choose the Connection tab. 
7. Select the database file (use the Browse button to find the database file) 
8. Click on OK to confirm. 

 
If you are creating a UDL file for an ODBC database, or for advanced MS Access 
use, you may also need to make certain entries in Database Setup (see 
Database Setup section). 
 
 

Trouble Shooting 
 
(If you get an error message ‘Syntax error in INSERT INTO Statement’ then most 
likely the database has incompatible field names. Check the field names for reserved 
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words, incompatible special characters, spaces in the name, field names starting with a 
number.  Please see the rest of this section for more information.)   
 
 
 

Copyright and Trademarks 
 
 
Copyright 2006-2010 Informatik Inc and J Buchmann.  All Rights Reserved. 
‘Informatik Archiver’ is a trademark of Informatik Inc. 
 
Infothek ® is a Registered Trademark of Informatik Inc.  Informatik Archiver is a 
trademark of Informatik Inc.  NET Framework and Microsoft Access are trademarks of 
Microsoft Corporation.  Other product names and expressions may be trademarks of the 
respective owners. 
 
See separate Copyright and Licensing notices in the ‘OCR Informatik’ program. 
 
 
 

Technical Support 
 
For contact information, please visit www.informatik.com/company.html 
 
 

Licensing 
 
For Licensing and ordering information, please visit www.informatik.com. 
 
 

Related Software 
 
Informatik Inc offers a host of other software products, including: 
 
Scanning software:  Informatik Scan 
Manipulation of TIFF and PDF Pages:  AppendTIFF, AppendPDF 
Markup of TIFF and PDF Files: Informatik Image Markup, PDF Markup) 
PDF utilities: TIFF-to-PDF, PDF-to-TIFF 
TIFF and PDF drivers 
TIFF and image files development tools 
And more 
 
Please visit www.informatik.com 
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License, Warranty, Disclaimer  
 
Please read the terms carefully before installing and using the software, as such conduct 
will indicate your acceptance of all of the terms of this license agreement.  If you do not 
agree with the terms, the software cannot be licensed to you and you must un-install and 
return the software to Informatik Inc, or its supplier or distributor. 
 
This License Agreement is a legal agreement between Informatik Inc. ("Licensor"), a 
Delaware Corporation, and you, the user ("Licensee"), and is effective the date Licensee 
installs the software. 
 
This Agreement covers all materials associated with the Informatik Archiver software, 
including, without limitation, the downloadable software product, online documentation, 
and any additional supporting electronic files (herein, the "Software"). 
 
The evaluation version may be used for 30 days after installation.  It is unlawful to use 
the software after the 30 day evaluation period without licensing the software and paying 
the license fees.  If a license is not obtained before the expiration of the 30 day 
evaluation period, the Software must be un-installed and destroyed. 
 
1. GRANT OF LICENSE 
Licensor hereby grants to you, and you accept, a nonexclusive license to use the 
Software according to the following condition: 
 
You may use the Software on one (1) computer (PC or workstation) owned, leased, or 
otherwise controlled by you for personal or business purposes, and only as authorized in 
this License Agreement.  The Software may not be used on other computers, nor may it 
be used by, or transferred to, other computers over a network.  The program may not be 
used on a web server. 
 
2. LICENSOR'S RIGHTS 
Licensee acknowledges and agrees that the Software is proprietary to Licensor and 
protected under international copyright law. Licensee further acknowledges and agrees 
that all right, title, and interests in and to the Software, including associated intellectual 
property rights, are and shall remain with Licensor. The License Agreement does not 
convey to Licensee an interest in or to the Software, but only a limited right of use that 
may be revoked in accordance with the terms of this License Agreement. 
 
3. OTHER RESTRICTIONS 
This License Agreement strictly forbids distribution of the Software with Licensee's 
application. Distribution of the Software with Licensee's application requires separate 
authorization and the payment of license fees. 
  
Licensee agrees to make no more than one (1) back-up copy of the Software. Licensee 
agrees not to assign, sublicense, transfer, pledge, lease, rent, or share the rights 
assigned under this License Agreement. Licensee agrees not to reverse assemble, 
reverse compile, or otherwise translate the Software. 
 
4. TERM 
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This License Agreement is effective when Licensee installs the Software and shall 
terminate only if the terms of this License Agreement are broken. Licensee agrees to 
destroy the Software upon termination of this License Agreement. 
 
5. NO WARRANTY; LIMITATION OF LIABILITY 
LICENSEE ACKNOWLEDGES THAT THE PROGRAM IS PROVIDED ON AN "AS IS" 
BASIS WITHOUT WARRANTY OF ANY KIND. LICENSOR MAKES NO 
REPRESENTATIONS OR WARRANTIES REGARDING THE USE OR 
PERFORMANCE OF THE SOFTWARE. LICENSOR incl. DEVELOPER, 
COPYRIGHTHOLDER, DISTRIBUTOR) EXPRESSLY DISCLAIMS THE WARRANTIES 
OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. LICENSOR 
SHALL HAVE NO LIABILITY TO LICENSEE OR ANY THIRD PARTY FOR ANY LOSS 
OR DAMAGE CAUSED, DIRECTLY  
OR INDIRECTLY, BY THE SOFTWARE, INCLUDING, BUT NOT LIMITED TO, ANY 
INTERRUPTION OF SERVICES, LOSS OF BUSINESS, LOSS OF DATA OR SPECIAL, 
CONSEQUENTIAL OR INCIDENTAL DAMAGES. 
 
6. GOVERNING LAW 
This License Agreement shall be construed and governed in accordance with the laws of 
Pennsylvania.  
 
7. SEVERABILITY 
Should any court of competent jurisdiction declare any term of this License Agreement 
void or unenforceable, such declaration will have no effect on the remaining terms 
hereof. 
 
8. NO WAIVER 
The failure of either party to enforce any rights granted hereunder or to take action 
against the other party in the event of any breach hereunder shall not be deemed a 
waiver by that party as to subsequent enforcement of rights or subsequent actions in the 
event of future breaches. 
 
 
 
 
 
 


